summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-11 08:10:43 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-11 08:10:43 +0000
commitdcc3edea059df99741a00adc4d5234dc9d8167ef (patch)
tree408a4a97dab4b0ff305476058541c36c6b0f7149
parentFix building with libpng-1.4. (diff)
downloademacs-patches-emacs-18.59-patches-5.tar.gz
emacs-patches-emacs-18.59-patches-5.tar.bz2
emacs-patches-emacs-18.59-patches-5.zip
-rw-r--r--emacs/18.59/07_all_cpp-4.5.patch15
-rw-r--r--emacs/21.4/22_all_cpp-4.5.patch25
-rw-r--r--emacs/22.3/07_all_cpp-4.5.patch25
-rw-r--r--emacs/23.1/06_all_cpp-4.5.patch25
4 files changed, 90 insertions, 0 deletions
diff --git a/emacs/18.59/07_all_cpp-4.5.patch b/emacs/18.59/07_all_cpp-4.5.patch
new file mode 100644
index 0000000..5750d5e
--- /dev/null
+++ b/emacs/18.59/07_all_cpp-4.5.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/308653
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
+Fix building with GNU CPP 4.5.
+
+--- emacs-18.59-orig/src/Makefile
++++ emacs-18.59/src/Makefile
+@@ -33,7 +33,7 @@
+ xmakefile: ymakefile config.h
+ -rm -f xmakefile junk.c
+ cp ymakefile junk.c
+- $(CPP) junk.c | sed -e 's/^#.*//' -e 's/^[ ][ ]*$$//' -e 's/^ / /' | \
++ $(CPP) -P junk.c | sed -e 's/^#.*//' -e 's/^[ ][ ]*$$//' -e 's/^ / /' | \
+ sed -n -e '/^..*$$/p' > xmakefile
+ rm -f junk.c
+
diff --git a/emacs/21.4/22_all_cpp-4.5.patch b/emacs/21.4/22_all_cpp-4.5.patch
new file mode 100644
index 0000000..9a09909
--- /dev/null
+++ b/emacs/21.4/22_all_cpp-4.5.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/308653
+http://debbugs.gnu.org/5047
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
+Fix building with GNU CPP 4.5, patch backported from upstream CVS.
+
+--- emacs-21.4-orig/configure.in
++++ emacs-21.4/configure.in
+@@ -2350,7 +2350,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
+@@ -2366,7 +2366,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $undefs -I. -I$top_srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
diff --git a/emacs/22.3/07_all_cpp-4.5.patch b/emacs/22.3/07_all_cpp-4.5.patch
new file mode 100644
index 0000000..7cc391f
--- /dev/null
+++ b/emacs/22.3/07_all_cpp-4.5.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/308653
+http://debbugs.gnu.org/5047
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
+Fix building with GNU CPP 4.5, patch from upstream CVS.
+
+--- emacs-22.3-orig/configure.in
++++ emacs-22.3/configure.in
+@@ -3388,7 +3388,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
+@@ -3404,7 +3404,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
diff --git a/emacs/23.1/06_all_cpp-4.5.patch b/emacs/23.1/06_all_cpp-4.5.patch
new file mode 100644
index 0000000..fdb3f48
--- /dev/null
+++ b/emacs/23.1/06_all_cpp-4.5.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/308653
+http://debbugs.gnu.org/5047
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
+Fix building with GNU CPP 4.5, patch from upstream CVS.
+
+--- emacs-23.1-orig/configure.in
++++ emacs-23.1/configure.in
+@@ -2983,7 +2983,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
+@@ -2999,7 +2999,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c