summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/23.1/06_all_cpp-4.5.patch')
-rw-r--r--emacs/23.1/06_all_cpp-4.5.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/emacs/23.1/06_all_cpp-4.5.patch b/emacs/23.1/06_all_cpp-4.5.patch
new file mode 100644
index 0000000..fdb3f48
--- /dev/null
+++ b/emacs/23.1/06_all_cpp-4.5.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/308653
+http://debbugs.gnu.org/5047
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
+Fix building with GNU CPP 4.5, patch from upstream CVS.
+
+--- emacs-23.1-orig/configure.in
++++ emacs-23.1/configure.in
+@@ -2983,7 +2983,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
+@@ -2999,7 +2999,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c