summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/22.3/07_all_cpp-4.5.patch')
-rw-r--r--emacs/22.3/07_all_cpp-4.5.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/emacs/22.3/07_all_cpp-4.5.patch b/emacs/22.3/07_all_cpp-4.5.patch
new file mode 100644
index 0000000..7cc391f
--- /dev/null
+++ b/emacs/22.3/07_all_cpp-4.5.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/308653
+http://debbugs.gnu.org/5047
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41748
+Fix building with GNU CPP 4.5, patch from upstream CVS.
+
+--- emacs-22.3-orig/configure.in
++++ emacs-22.3/configure.in
+@@ -3388,7 +3388,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c
+@@ -3404,7 +3404,7 @@
+ sed -e '1,/start of cpp stuff/d'\
+ -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
+ < Makefile.c > junk.c
+- $CPP $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
++ $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
+ sed -e 's/^ / /' -e '/^#/d' -e '/^[ ]*$/d' > junk2.c
+ cat junk1.c junk2.c > Makefile.new
+ rm -f junk.c junk1.c junk2.c