aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-08-30 09:02:43 +0300
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-08-30 10:42:27 +0300
commit2db6bd62b0cb286c784f6cf353c9302abe4cccf3 (patch)
treef7dcf7503938bac1ba08911f2638aed2b9008a57
parentsys-fs/btdu: new package, add 0.5.1 (diff)
downloaddlang-2db6bd62b0cb286c784f6cf353c9302abe4cccf3.tar.gz
dlang-2db6bd62b0cb286c784f6cf353c9302abe4cccf3.tar.bz2
dlang-2db6bd62b0cb286c784f6cf353c9302abe4cccf3.zip
net-misc/onedrive: enable dmd-2_109 and ldc2-1_39
Additionally: - add RESTRICT=test because tests weren't being run anyway and there's no easy way to do it. - dropped messages about upgrading from version 2.3 which is from 4 years ago - reorder some variables Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
-rw-r--r--net-misc/onedrive/onedrive-2.4.25-r1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/net-misc/onedrive/onedrive-2.4.25-r1.ebuild b/net-misc/onedrive/onedrive-2.4.25-r1.ebuild
index b88b785..14fa9e7 100644
--- a/net-misc/onedrive/onedrive-2.4.25-r1.ebuild
+++ b/net-misc/onedrive/onedrive-2.4.25-r1.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+DLANG_COMPAT=( dmd-2_{106..109} ldc2-1_{35..39} )
+inherit bash-completion-r1 dlang-single systemd
+
DESCRIPTION="Free Client for OneDrive on Linux"
HOMEPAGE="https://abraunegg.github.io/"
SRC_URI="https://codeload.github.com/abraunegg/onedrive/tar.gz/v${PV} -> ${P}.tar.gz"
@@ -10,11 +13,9 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# no straight forward way to run unittests. Probably need to do DFLAGS=-unittest econf
IUSE="debug libnotify"
-
-DLANG_COMPAT=( dmd-2_{106..108} ldc2-1_{35..38} )
-
-inherit dlang-single systemd bash-completion-r1
+RESTRICT=test
REQUIRED_USE=${DLANG_REQUIRED_USE}
RDEPEND="
@@ -55,8 +56,4 @@ pkg_postinst() {
elog "OneDrive Free Client needs to be authorized to access your data before the"
elog "first use. To do so, run onedrive in a terminal for the user in question and"
elog "follow the steps on screen."
- elog
- ewarn "When upgrading from 2.3 you are required to reauthorise your client."
- ewarn "This is due to changing the client identifier to assist with resolving"
- ewarn "the correct handling of 429 error responses (activityLimitReached)"
}