aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-08-15 22:30:50 +0300
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-08-30 10:32:54 +0300
commitdd17942a7849f33fcffea094a5de86dab023f7fe (patch)
tree604ec5f67d4c440e24dd391d4333543da5179de5
parentdev-util/serve-d: add 0.8.0_beta17 (diff)
downloaddlang-dd17942a7849f33fcffea094a5de86dab023f7fe.tar.gz
dlang-dd17942a7849f33fcffea094a5de86dab023f7fe.tar.bz2
dlang-dd17942a7849f33fcffea094a5de86dab023f7fe.zip
sys-fs/btdu: new package, add 0.5.1
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me> Closes: https://github.com/gentoo/dlang/pull/131 Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
-rw-r--r--sys-fs/btdu/Manifest5
-rw-r--r--sys-fs/btdu/btdu-0.5.1.ebuild45
-rw-r--r--sys-fs/btdu/metadata.xml7
3 files changed, 57 insertions, 0 deletions
diff --git a/sys-fs/btdu/Manifest b/sys-fs/btdu/Manifest
new file mode 100644
index 0000000..d956f89
--- /dev/null
+++ b/sys-fs/btdu/Manifest
@@ -0,0 +1,5 @@
+DIST ae-0.0.3236.zip 670165 BLAKE2B d6ca10a81a235bc2d19dc5c46f25158a19ebf950a7878d29723bf464c4a8f9d113a0084694f0ceafdf1ba3db6f11992961ce490747b2cbc171642e9f05846d8c SHA512 bf758929c839f80c07a301388b57813f9864a75504b6cc3019d43b887ee03f8321327f3e0bacf33053b60153ad50142869b9e2a7d0c7cbe35b1c2ec3c529b9c1
+DIST btdu-0.5.1.zip 59342 BLAKE2B 7401e49cc43d879af6bb69d1e8d39daaaafece4c5320797cd6fa14bdb040f553c1fc27124c095d5b0e075b8252ed948cab3d676b7db307b6d8e5343846cee0fb SHA512 aaa1e34caa9087101b0d50f32b55a27d9cc3118774fac1320d5d214c12f6971f1cd89fe6dae8184e8c61b980ec78bd58fbc373031e8dcd38b751be083a5fb327
+DIST btrfs-0.0.18.zip 47737 BLAKE2B 3b539559dfa4a0cfe3265144f5d72f316517d5276b6ced8340e6377864ecf61bb2188db844095cf5d29fbb2b4e19bf49e685b339f075154f00250bc0ac96b6ba SHA512 044960d27032e7d6ee70cd4aaca5c9a59f2c8ad54222be1da7710ade50d3c0cab72cabb4474cd1045484959b00921307a67d79eef3afd80e7be781320ddd33eb
+DIST emsi_containers-0.9.0.zip 70600 BLAKE2B e00d94acde01f5757928bda3adad945dcb38692544f91011aa05ff2fbd859f00c5ba67d1ec3bda5f4c90d42086d1ea65d418dafd02abdc8a7a7854707b2ebaf1 SHA512 cf599b675860bb91958bf78ba225e0d1755fec49ca1c1854d71f05ead6fd6037c30dfcc351e68accdbf42b9acc87c05731b8f8ac123962560869f46d4843c004
+DIST ncurses-1.0.0.zip 164010 BLAKE2B 43eaaad7e86c198f3b1918f8c06c7b0e70609d8fc905a02f00ac2b6344962cd40c79f9a26f765d8823cef8f83b8c742eff5642bd7e0ece7f98c094092eb8025c SHA512 908934f17b65014c741ef0f22eb2e8cbcf67a5b784326c614773c690bdfb236fd3c58a32f94762e62737f4c26b7318fcbe69284fdcd9ae67a125af2aa446e165
diff --git a/sys-fs/btdu/btdu-0.5.1.ebuild b/sys-fs/btdu/btdu-0.5.1.ebuild
new file mode 100644
index 0000000..99a72d8
--- /dev/null
+++ b/sys-fs/btdu/btdu-0.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# gdc-13 is disabled due to: https://gcc.gnu.org/PR111650
+# gdc-14 is disabled due to: https://gcc.gnu.org/PR116373
+DLANG_COMPAT=( dmd-2_10{6..9} ldc2-1_3{5..9} )
+DUB_DEPENDENCIES=(
+ "ae@0.0.3236"
+ "btdu@0.5.1"
+ "btrfs@0.0.18"
+ "emsi_containers@0.9.0"
+ "ncurses@1.0.0"
+)
+inherit dlang-single dub
+
+DESCRIPTION="Sampling disk usage profiler for btrfs"
+HOMEPAGE="https://github.com/CyberShadow/btdu"
+SRC_URI="${DUB_DEPENDENCIES_URIS}"
+
+LICENSE="GPL-2"
+LICENSE+=" Boost-1.0 GPL-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+# Relevant tests require a btrfs filesystem.
+RESTRICT="test"
+
+COMMON_DEPEND="sys-libs/zlib sys-libs/ncurses:="
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+DOCS=( README.md CONCEPTS.md )
+
+src_test() {
+ # Enabling unittests runs the unittests in the dependencies which
+ # may not all be relevant for this package.
+ edub test --build=unittest
+}
+
+src_install() {
+ dobin "${S}/btdu"
+ doman btdu.1
+ einstalldocs
+}
diff --git a/sys-fs/btdu/metadata.xml b/sys-fs/btdu/metadata.xml
new file mode 100644
index 0000000..6a96176
--- /dev/null
+++ b/sys-fs/btdu/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">CyberShadow/btdu</remote-id>
+ </upstream>
+</pkgmetadata>