summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild (renamed from sci-mathematics/dunshire/dunshire-0.1.3.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
index ac63ace2d98f..36354f6a301d 100644
--- a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
+++ b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
@@ -19,8 +19,12 @@ RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
DOCS=( doc/README.rst )
distutils_enable_sphinx doc/source
+
+# There are no additional dependencies even though we're not really
+# using setup.py to run the test suite any more. The __main__.py
+# runner has its own exit code handling.
distutils_enable_tests setup.py
python_test() {
- esetup.py test
+ PYTHONPATH="." "${EPYTHON}" test/__main__.py --verbose
}