summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-08-04 22:06:11 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-08-04 22:07:06 -0400
commit5a2f1b6fc00dc71645a0fd06b742ee05d6c51159 (patch)
treee00af138515d58f852e10c3c73c90b6bfa614b42 /sci-mathematics
parentmedia-libs/raptor: Stabilize 2.0.16 ppc, #937305 (diff)
downloadgentoo-5a2f1b6fc00dc71645a0fd06b742ee05d6c51159.tar.gz
gentoo-5a2f1b6fc00dc71645a0fd06b742ee05d6c51159.tar.bz2
gentoo-5a2f1b6fc00dc71645a0fd06b742ee05d6c51159.zip
sci-mathematics/dunshire: don't use setup.py for tests
Closes: https://bugs.gentoo.org/937324 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild (renamed from sci-mathematics/dunshire/dunshire-0.1.3.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
index ac63ace2d98f..36354f6a301d 100644
--- a/sci-mathematics/dunshire/dunshire-0.1.3.ebuild
+++ b/sci-mathematics/dunshire/dunshire-0.1.3-r1.ebuild
@@ -19,8 +19,12 @@ RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
DOCS=( doc/README.rst )
distutils_enable_sphinx doc/source
+
+# There are no additional dependencies even though we're not really
+# using setup.py to run the test suite any more. The __main__.py
+# runner has its own exit code handling.
distutils_enable_tests setup.py
python_test() {
- esetup.py test
+ PYTHONPATH="." "${EPYTHON}" test/__main__.py --verbose
}