summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-05 03:08:42 +0100
committerSam James <sam@gentoo.org>2024-10-05 03:08:51 +0100
commitb57ec2cd26d3ca4951dbaad3ebdb3915d0c6e78c (patch)
treeafd755182175e2eb6cc1a3be1845f3677ba8557c /app-forensics
parentmedia-libs/alsa-lib: enable py3.13 (diff)
downloadgentoo-b57ec2cd26d3ca4951dbaad3ebdb3915d0c6e78c.tar.gz
gentoo-b57ec2cd26d3ca4951dbaad3ebdb3915d0c6e78c.tar.bz2
gentoo-b57ec2cd26d3ca4951dbaad3ebdb3915d0c6e78c.zip
app-forensics/aflplusplus: fix man page
Closes: https://bugs.gentoo.org/940252 Thanks-to: Nick Bowler <nbowler@draconx.ca> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild b/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
index 0431fd829024..09e9bd1defec 100644
--- a/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
+++ b/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
@@ -67,7 +67,17 @@ pkg_setup() {
}
mymake() {
- emake \
+ # afl-fuzz spews garbage to stdout if the environment contains any
+ # variables whose name beginning with USE_ (including the underscore),
+ # regardless of their value (even if empty!). The ebuild environment
+ # contains several such variables and the garbage that gets printed
+ # ends up in the generated man page.
+ #
+ # We can work around the problem by unsetting all these variables when
+ # running make.
+ local badvars=("${!USE_@}")
+
+ env "${badvars[@]/#/-u}" emake \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
CFLAGS_FLTO="" \