summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild b/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
index 0431fd829024..09e9bd1defec 100644
--- a/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
+++ b/app-forensics/aflplusplus/aflplusplus-4.08c-r1.ebuild
@@ -67,7 +67,17 @@ pkg_setup() {
}
mymake() {
- emake \
+ # afl-fuzz spews garbage to stdout if the environment contains any
+ # variables whose name beginning with USE_ (including the underscore),
+ # regardless of their value (even if empty!). The ebuild environment
+ # contains several such variables and the garbage that gets printed
+ # ends up in the generated man page.
+ #
+ # We can work around the problem by unsetting all these variables when
+ # running make.
+ local badvars=("${!USE_@}")
+
+ env "${badvars[@]/#/-u}" emake \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
CFLAGS_FLTO="" \