summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/cfv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/cfv')
-rw-r--r--app-arch/cfv/Manifest2
-rw-r--r--app-arch/cfv/cfv-1.18.2.ebuild32
-rw-r--r--app-arch/cfv/cfv-1.18.3-r1.ebuild41
-rw-r--r--app-arch/cfv/files/cfv-1.18.1-modulefix.patch21
-rw-r--r--app-arch/cfv/metadata.xml19
5 files changed, 115 insertions, 0 deletions
diff --git a/app-arch/cfv/Manifest b/app-arch/cfv/Manifest
new file mode 100644
index 000000000000..e55a88580e36
--- /dev/null
+++ b/app-arch/cfv/Manifest
@@ -0,0 +1,2 @@
+DIST cfv-1.18.2.tar.gz 67970 SHA256 73fc368e3717cdc7062c3c909778d03d15128bc9a18a76c7e4f7a75e8a99f391 SHA512 8999349485a404b71aec8abe21b554a867c6a94ed77dda2441f418c5798a243039685d72ccfb5e020885c8bab2a571da48d98a3171339bf14becfacca3ae5508 WHIRLPOOL b6d2d19bb69975b3cecfd884be034983318e118ee609dea0ebd9491a42c945a53e0e613daafd99fdc76542364013749989880ebe6969e8acdd3a48e3a942bb18
+DIST cfv-1.18.3.tar.gz 68030 SHA256 ff28a8aa679932b83eb3b248ed2557c6da5860d5f8456ffe24686253a354cff6 SHA512 dbca82df850703ab68a20db9314475025ac2e7012f34a12abbb358677e81cbb29a465adf4a1b002f6cf1c1dd84f1588fc1072791d6bbaad0c02cc563e5fe7d71 WHIRLPOOL 895211c61ff57068f28945fd374d3b9e2f00dc2739e1b884bbdb7cfa0a799d50ee36ff6791bb6457e2eba5f613a8b57b77bd1b3bacc7c4a329f0326d58375b13
diff --git a/app-arch/cfv/cfv-1.18.2.ebuild b/app-arch/cfv/cfv-1.18.2.ebuild
new file mode 100644
index 000000000000..0b754c212a7e
--- /dev/null
+++ b/app-arch/cfv/cfv-1.18.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
+HOMEPAGE="http://cfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cfv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 hppa ppc sparc x86 ~x86-fbsd"
+
+DEPEND=""
+RDEPEND="dev-python/python-fchksum"
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin cfv || die "dobin failed"
+ doman cfv.1 || die "doman failed"
+ dodoc README Changelog || die "dodoc failed"
+ python_convert_shebangs -r 2 "${ED}"
+}
diff --git a/app-arch/cfv/cfv-1.18.3-r1.ebuild b/app-arch/cfv/cfv-1.18.3-r1.ebuild
new file mode 100644
index 000000000000..36211539d28d
--- /dev/null
+++ b/app-arch/cfv/cfv-1.18.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Utility to test and create .sfv, .csv, .crc and md5sum files"
+HOMEPAGE="http://cfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cfv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="bittorrent"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-fchksum[${PYTHON_USEDEP}]
+ bittorrent? (
+ || (
+ net-p2p/bittorrent[${PYTHON_USEDEP}]
+ net-p2p/bittornado[${PYTHON_USEDEP}]
+ )
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ python_fix_shebang cfv
+ dobin cfv
+ doman cfv.1
+ dodoc README Changelog
+}
diff --git a/app-arch/cfv/files/cfv-1.18.1-modulefix.patch b/app-arch/cfv/files/cfv-1.18.1-modulefix.patch
new file mode 100644
index 000000000000..a415a3afc8bb
--- /dev/null
+++ b/app-arch/cfv/files/cfv-1.18.1-modulefix.patch
@@ -0,0 +1,21 @@
+--- branches/cfv-1_x-branch/cfv/cfv 2006/03/28 07:29:01 340
++++ branches/cfv-1_x-branch/cfv/cfv 2007/03/04 01:57:56 401
+@@ -1360,12 +1360,15 @@
+ #---------- .torrent ----------
+ _btimporterror = None
+ try:
+- from BitTorrent import bencode, btformats
++ from BTL import bencode, btformats
+ except ImportError, e1:
+ try:
+- from BitTornado import bencode; from BitTornado.BT1 import btformats
++ from BitTorrent import bencode, btformats
+ except ImportError, e2:
+- _btimporterror = '%s and %s'%(e1,e2)
++ try:
++ from BitTornado import bencode; from BitTornado.BT1 import btformats
++ except ImportError, e3:
++ _btimporterror = '%s and %s and %s'%(e1,e2,e3)
+
+ class Torrent(ChksumType):
+ description = 'BitTorrent metainfo'
diff --git a/app-arch/cfv/metadata.xml b/app-arch/cfv/metadata.xml
new file mode 100644
index 000000000000..9a061aa30829
--- /dev/null
+++ b/app-arch/cfv/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ cfv is a utility to both test and create .sfv, .csv, .crc,
+ .md5(sfv-like), md5sum, bsd md5, sha1sum, and .torrent files. These
+ files are commonly used to ensure the correct retrieval or storage of
+ data.
+ </longdescription>
+ <use>
+ <flag name="bittorrent">Enable support for checking .torrent files</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">cfv</remote-id>
+ </upstream>
+</pkgmetadata>