summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 20:05:43 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 20:05:43 +0000
commit8e59ca757cb523bbd302a47267f72c3f32b38596 (patch)
tree23abe7e956aa82b67343ef04a3724a81b2372904 /sys-devel
parent*** empty log message *** (diff)
downloadhistorical-8e59ca757cb523bbd302a47267f72c3f32b38596.tar.gz
historical-8e59ca757cb523bbd302a47267f72c3f32b38596.tar.bz2
historical-8e59ca757cb523bbd302a47267f72c3f32b38596.zip
*** empty log message ***
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/gdb-5.0-r2.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-devel/gdb/gdb-5.0-r2.ebuild b/sys-devel/gdb/gdb-5.0-r2.ebuild
index b4042be6a476..cddc2ce54bc4 100644
--- a/sys-devel/gdb/gdb-5.0-r2.ebuild
+++ b/sys-devel/gdb/gdb-5.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.2 2001/02/07 20:05:43 achim Exp $
A=${P}.tar.bz2
S=${WORKDIR}/${P}
@@ -10,15 +10,23 @@ SRC_URI="ftp://sourceware.cygnus.com/pub/gdb/releases/${A}
ftp://ftp.freesoftware.com/pub/sourceware/gdb/releases/${A}"
DEPEND=">=sys-libs/ncurses-5.2-r2
+ sys-libs/readline-4.1-r2
sys-devel/gettext"
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND=">=sys-libs/ncurses-5.2-r2 sys-libs/readline-4.1-r2"
HOMEPAGE="http://www.gnu.org/software/gdb/gdb.html"
src_compile() {
- try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
+ local myconf
+ if [ "`use gdbm`" ]
+ then
+ myconf="--endable-gdbmi"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --without-included-regex --without-included-gettext --enable-shared --host=${CHOST}
try make ${MAKEOPTS}
}