summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/grub/grub-0.5.96.1-r2.ebuild7
-rw-r--r--sys-devel/gdb/gdb-5.0-r2.ebuild14
2 files changed, 15 insertions, 6 deletions
diff --git a/sys-apps/grub/grub-0.5.96.1-r2.ebuild b/sys-apps/grub/grub-0.5.96.1-r2.ebuild
index 6ca49979acd6..7e35c9a881eb 100644
--- a/sys-apps/grub/grub-0.5.96.1-r2.ebuild
+++ b/sys-apps/grub/grub-0.5.96.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.5.96.1-r2.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.5.96.1-r2.ebuild,v 1.2 2001/02/07 20:05:43 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -14,9 +14,10 @@ DEPEND="virtual/glibc
src_compile() {
- try ./configure --prefix=/usr \
+ try ./configure --prefix=/usr \
--mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
- try make ${MAKEOPTS}
+
+ try make ${MAKEOPTS} -e CPPFLAGS=\"-Wall -Wmissing-prototypes -Wunused -Wshadow -malign-jumps=1 -malign-loops=1 -malign-functions=1 -Wundef\"
}
src_install() {
diff --git a/sys-devel/gdb/gdb-5.0-r2.ebuild b/sys-devel/gdb/gdb-5.0-r2.ebuild
index b4042be6a476..cddc2ce54bc4 100644
--- a/sys-devel/gdb/gdb-5.0-r2.ebuild
+++ b/sys-devel/gdb/gdb-5.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.2 2001/02/07 20:05:43 achim Exp $
A=${P}.tar.bz2
S=${WORKDIR}/${P}
@@ -10,15 +10,23 @@ SRC_URI="ftp://sourceware.cygnus.com/pub/gdb/releases/${A}
ftp://ftp.freesoftware.com/pub/sourceware/gdb/releases/${A}"
DEPEND=">=sys-libs/ncurses-5.2-r2
+ sys-libs/readline-4.1-r2
sys-devel/gettext"
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND=">=sys-libs/ncurses-5.2-r2 sys-libs/readline-4.1-r2"
HOMEPAGE="http://www.gnu.org/software/gdb/gdb.html"
src_compile() {
- try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
+ local myconf
+ if [ "`use gdbm`" ]
+ then
+ myconf="--endable-gdbmi"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --without-included-regex --without-included-gettext --enable-shared --host=${CHOST}
try make ${MAKEOPTS}
}