summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-08 04:30:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-08 04:30:59 +0000
commit24633df01892c71789b485dfd628b3e9ff20b5fb (patch)
treebb9989d11c8c323fef3899bcc23c00dd00ab915d /media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild
parentversion bump (diff)
downloadhistorical-24633df01892c71789b485dfd628b3e9ff20b5fb.tar.gz
historical-24633df01892c71789b485dfd628b3e9ff20b5fb.tar.bz2
historical-24633df01892c71789b485dfd628b3e9ff20b5fb.zip
version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.3 x86_64
Diffstat (limited to 'media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild')
-rw-r--r--media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild b/media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild
new file mode 100644
index 000000000000..a627d802c378
--- /dev/null
+++ b/media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3splt-gtk/mp3splt-gtk-0.5.ebuild,v 1.1 2008/09/08 04:30:59 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="a GTK+ based utility to split mp3 and ogg files without decoding."
+HOMEPAGE="http://mp3splt.sourceforge.net"
+SRC_URI="mirror://sourceforge/mp3splt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=media-libs/libmp3splt-0.5"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry ${PN} mp3splt ${PN}
+}