summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 16:40:34 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 16:40:34 +0000
commite87ab9b21ff581e198f6a7e79ce64000a723744c (patch)
tree97c4d1bb8b9bb6c84fc21a7289be405c90db30ee /dev-libs/libdbusmenu/files
parentstable x86, bug 309693 (diff)
downloadhistorical-e87ab9b21ff581e198f6a7e79ce64000a723744c.tar.gz
historical-e87ab9b21ff581e198f6a7e79ce64000a723744c.tar.bz2
historical-e87ab9b21ff581e198f6a7e79ce64000a723744c.zip
Initial commit, moved from kde overlay, thanks to Dennis Schridde
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libdbusmenu/files')
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch37
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch44
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch10
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch
new file mode 100644
index 000000000000..2eb0eedcb870
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch
@@ -0,0 +1,37 @@
+--- configure.ac.orig 2010-03-31 12:56:17.483842274 +0200
++++ configure.ac 2010-03-31 12:57:25.783592956 +0200
+@@ -42,10 +42,17 @@
+
+ GTK_REQUIRED_VERSION=2.16
+
++AC_ARG_ENABLE([gtk],
++ AC_HELP_STRING([--disable-gtk], [Disable libindicate-gtk library]),
++ [enable_gtk=$enableval], enable_gtk=auto)
++AM_CONDITIONAL([WANT_LIBDBUSMENUGTK], [test "x$enable_gtk" != "xno"])
++
++if test "x$enable_gtk" != "xno"; then
+ PKG_CHECK_MODULES(DBUSMENUGTK, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION
+ libxml-2.0 >= $XML_REQUIRED_VERSION)
++fi
+
+ AC_SUBST(DBUSMENUGTK_CFLAGS)
+ AC_SUBST(DBUSMENUGTK_LIBS)
+--- Makefile.am.orig 2010-03-31 13:01:21.871844609 +0200
++++ Makefile.am 2010-03-31 13:19:34.896594837 +0200
+@@ -5,10 +5,13 @@
+
+ SUBDIRS = \
+ libdbusmenu-glib \
+- libdbusmenu-gtk \
+ tools \
+ tests \
+ po
+
++if WANT_LIBDBUSMENUGTK
++SUBDIRS += libdbusmenu-gtk
++endif
++
+ DISTCHECK_CONFIGURE_FLAGS = --enable-introspection
+
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch
new file mode 100644
index 000000000000..1733c0576a4e
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch
@@ -0,0 +1,44 @@
+--- configure.ac.orig 2010-03-31 12:56:17.483842274 +0200
++++ configure.ac 2010-03-31 13:08:36.291843605 +0200
+@@ -56,7 +56,14 @@
+
+ JSON_GLIB_REQUIRED_VERSION=0.6.0
+
++AC_ARG_ENABLE([tests],
++ AC_HELP_STRING([--disable-tests], [Disable tests]),
++ [enable_tests=$enableval], enable_tests=auto)
++AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
++
++if test "x$enable_tests" != "xno"; then
+ PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION)
++fi
+
+ AC_SUBST(DBUSMENUTESTS_CFLAGS)
+ AC_SUBST(DBUSMENUTESTS_LIBS)
+--- Makefile.am.orig 2010-03-31 13:01:21.871844609 +0200
++++ Makefile.am 2010-03-31 13:33:03.953843279 +0200
+@@ -7,7 +7,10 @@
+ libdbusmenu-glib \
+ tools \
+- tests \
+ po
+
++if WANT_TESTS
++SUBDIRS += tests
++endif
++
+ DISTCHECK_CONFIGURE_FLAGS = --enable-introspection
+
+--- tools/Makefile.am.orig 2010-03-31 13:44:57.924843955 +0200
++++ tools/Makefile.am 2010-03-31 13:47:19.073593832 +0200
+@@ -1,5 +1,9 @@
+
+-SUBDIRS = testapp
++SUBDIRS =
++
++if WANT_TESTS
++SUBDIRS += testapp
++endif
+
+ libexec_PROGRAMS = dbusmenu-dumper
+
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch
new file mode 100644
index 000000000000..8e76ca8da47d
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2010-03-31 12:42:16.497596552 +0200
++++ configure.ac 2010-03-31 12:42:47.001595062 +0200
+@@ -74,6 +74,6 @@
+ ###########################
+
+-GOBJECT_INTROSPECTION_CHECK([0.6.7])
++AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
+
+ ###########################
+ # GTK Doc