summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch')
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch
new file mode 100644
index 000000000000..1733c0576a4e
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch
@@ -0,0 +1,44 @@
+--- configure.ac.orig 2010-03-31 12:56:17.483842274 +0200
++++ configure.ac 2010-03-31 13:08:36.291843605 +0200
+@@ -56,7 +56,14 @@
+
+ JSON_GLIB_REQUIRED_VERSION=0.6.0
+
++AC_ARG_ENABLE([tests],
++ AC_HELP_STRING([--disable-tests], [Disable tests]),
++ [enable_tests=$enableval], enable_tests=auto)
++AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
++
++if test "x$enable_tests" != "xno"; then
+ PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION)
++fi
+
+ AC_SUBST(DBUSMENUTESTS_CFLAGS)
+ AC_SUBST(DBUSMENUTESTS_LIBS)
+--- Makefile.am.orig 2010-03-31 13:01:21.871844609 +0200
++++ Makefile.am 2010-03-31 13:33:03.953843279 +0200
+@@ -7,7 +7,10 @@
+ libdbusmenu-glib \
+ tools \
+- tests \
+ po
+
++if WANT_TESTS
++SUBDIRS += tests
++endif
++
+ DISTCHECK_CONFIGURE_FLAGS = --enable-introspection
+
+--- tools/Makefile.am.orig 2010-03-31 13:44:57.924843955 +0200
++++ tools/Makefile.am 2010-03-31 13:47:19.073593832 +0200
+@@ -1,5 +1,9 @@
+
+-SUBDIRS = testapp
++SUBDIRS =
++
++if WANT_TESTS
++SUBDIRS += testapp
++endif
+
+ libexec_PROGRAMS = dbusmenu-dumper
+