summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-Subnet')
-rw-r--r--dev-perl/Net-Subnet/Manifest1
-rw-r--r--dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild20
-rw-r--r--dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch15
-rw-r--r--dev-perl/Net-Subnet/metadata.xml8
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Net-Subnet/Manifest b/dev-perl/Net-Subnet/Manifest
new file mode 100644
index 000000000000..b7c972e8c8de
--- /dev/null
+++ b/dev-perl/Net-Subnet/Manifest
@@ -0,0 +1 @@
+DIST Net-Subnet-1.03.tar.gz 4305 SHA256 125e6db64c98026439f9b585115f94f42315a31d8f16ca63d0c939ab66019afa SHA512 a28518e63736021c2c33959c13b54ec4dce0f43854f824c551b585db96ef001e62f6ce413cbc946aaa6cfa28cc4631973074c8980c1b0507f37390f4d8c70fd4 WHIRLPOOL e031057d48a75a83c94c3fb206d4a3f864c60f459a8acc43126e562a60f2c35b12a2b90c2bf18ef1ecb96673e76eee5f1ed0c8450d5fb9003f92d7647dc0f2eb
diff --git a/dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild b/dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild
new file mode 100644
index 000000000000..d5eb2e0f9ffa
--- /dev/null
+++ b/dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JUERD
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="Fast IP-in-subnet matcher for IPv4 and IPv6, CIDR or mask"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-perl/Socket6-0.250.0
+"
+DEPEND="${RDEPEND}"
+PATCHES=( ${FILESDIR}/${PV}-pod-spelling.patch )
diff --git a/dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch b/dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch
new file mode 100644
index 000000000000..2a6b6f490319
--- /dev/null
+++ b/dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch
@@ -0,0 +1,15 @@
+Description: tiny spelling error in POD
+Author: Damyan Ivanov <dmn@debian.org>
+Forwarded: yes
+
+--- a/lib/Net/Subnet.pm
++++ b/lib/Net/Subnet.pm
+@@ -217,7 +217,7 @@ addresses:
+ my $classifier = subnet_classifier sort_subnets keys %ptr;
+
+ while (my $ip = readline) {
+- # We get IP adresses from STDIN and return the hostnames on STDOUT
++ # We get IP addresses from STDIN and return the hostnames on STDOUT
+
+ print $ptr{ $classifier->($ip) }->($ip), "\n";
+ }
diff --git a/dev-perl/Net-Subnet/metadata.xml b/dev-perl/Net-Subnet/metadata.xml
new file mode 100644
index 000000000000..05a8c1807054
--- /dev/null
+++ b/dev-perl/Net-Subnet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-Subnet</remote-id>
+ </upstream>
+</pkgmetadata>