summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-Subnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-Subnet')
-rw-r--r--dev-perl/Net-Subnet/Manifest1
-rw-r--r--dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild20
-rw-r--r--dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch15
-rw-r--r--dev-perl/Net-Subnet/metadata.xml8
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Net-Subnet/Manifest b/dev-perl/Net-Subnet/Manifest
new file mode 100644
index 000000000000..b7c972e8c8de
--- /dev/null
+++ b/dev-perl/Net-Subnet/Manifest
@@ -0,0 +1 @@
+DIST Net-Subnet-1.03.tar.gz 4305 SHA256 125e6db64c98026439f9b585115f94f42315a31d8f16ca63d0c939ab66019afa SHA512 a28518e63736021c2c33959c13b54ec4dce0f43854f824c551b585db96ef001e62f6ce413cbc946aaa6cfa28cc4631973074c8980c1b0507f37390f4d8c70fd4 WHIRLPOOL e031057d48a75a83c94c3fb206d4a3f864c60f459a8acc43126e562a60f2c35b12a2b90c2bf18ef1ecb96673e76eee5f1ed0c8450d5fb9003f92d7647dc0f2eb
diff --git a/dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild b/dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild
new file mode 100644
index 000000000000..d5eb2e0f9ffa
--- /dev/null
+++ b/dev-perl/Net-Subnet/Net-Subnet-1.30.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JUERD
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="Fast IP-in-subnet matcher for IPv4 and IPv6, CIDR or mask"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-perl/Socket6-0.250.0
+"
+DEPEND="${RDEPEND}"
+PATCHES=( ${FILESDIR}/${PV}-pod-spelling.patch )
diff --git a/dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch b/dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch
new file mode 100644
index 000000000000..2a6b6f490319
--- /dev/null
+++ b/dev-perl/Net-Subnet/files/1.30.0-pod-spelling.patch
@@ -0,0 +1,15 @@
+Description: tiny spelling error in POD
+Author: Damyan Ivanov <dmn@debian.org>
+Forwarded: yes
+
+--- a/lib/Net/Subnet.pm
++++ b/lib/Net/Subnet.pm
+@@ -217,7 +217,7 @@ addresses:
+ my $classifier = subnet_classifier sort_subnets keys %ptr;
+
+ while (my $ip = readline) {
+- # We get IP adresses from STDIN and return the hostnames on STDOUT
++ # We get IP addresses from STDIN and return the hostnames on STDOUT
+
+ print $ptr{ $classifier->($ip) }->($ip), "\n";
+ }
diff --git a/dev-perl/Net-Subnet/metadata.xml b/dev-perl/Net-Subnet/metadata.xml
new file mode 100644
index 000000000000..05a8c1807054
--- /dev/null
+++ b/dev-perl/Net-Subnet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-Subnet</remote-id>
+ </upstream>
+</pkgmetadata>