summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-03 16:41:46 +0100
committerSam James <sam@gentoo.org>2022-01-04 03:28:58 +0000
commit533b08b42299c909f4587eb04e82ae0f799d5048 (patch)
tree1372a9165e2e25c1ddd688f929ff9e148086a287 /sys-devel/clang
parentsys-block/tw_cli: remove kernel_FreeBSD (diff)
downloadgentoo-533b08b42299c909f4587eb04e82ae0f799d5048.tar.gz
gentoo-533b08b42299c909f4587eb04e82ae0f799d5048.tar.bz2
gentoo-533b08b42299c909f4587eb04e82ae0f799d5048.zip
sys-devel/clang: remove kernel_FreeBSD
Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-11.1.0.ebuild9
-rw-r--r--sys-devel/clang/clang-12.0.1.ebuild9
-rw-r--r--sys-devel/clang/clang-13.0.0.ebuild9
-rw-r--r--sys-devel/clang/clang-13.0.1.9999.ebuild9
-rw-r--r--sys-devel/clang/clang-13.0.1_rc1.ebuild9
-rw-r--r--sys-devel/clang/clang-14.0.0.9999.ebuild9
6 files changed, 12 insertions, 42 deletions
diff --git a/sys-devel/clang/clang-11.1.0.ebuild b/sys-devel/clang/clang-11.1.0.ebuild
index 844348ccef0f..70f90cdc03ee 100644
--- a/sys-devel/clang/clang-11.1.0.ebuild
+++ b/sys-devel/clang/clang-11.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,7 +24,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc +static-analyzer test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
+ doc +static-analyzer test xml ${ALL_LLVM_TARGETS[*]}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
@@ -383,11 +383,6 @@ src_install() {
"/usr/lib/llvm/${SLOT%/*}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {
diff --git a/sys-devel/clang/clang-12.0.1.ebuild b/sys-devel/clang/clang-12.0.1.ebuild
index b3ddd17937e3..e4b38d294772 100644
--- a/sys-devel/clang/clang-12.0.1.ebuild
+++ b/sys-devel/clang/clang-12.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,7 +24,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x64-macos"
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +static-analyzer test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
+ doc llvm-libunwind +static-analyzer test xml ${ALL_LLVM_TARGETS[*]}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
@@ -387,11 +387,6 @@ src_install() {
"/usr/lib/llvm/${SLOT}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {
diff --git a/sys-devel/clang/clang-13.0.0.ebuild b/sys-devel/clang/clang-13.0.0.ebuild
index 707bb762d95f..5aeac025e36c 100644
--- a/sys-devel/clang/clang-13.0.0.ebuild
+++ b/sys-devel/clang/clang-13.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x64-macos"
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +static-analyzer test xml kernel_FreeBSD"
+ doc llvm-libunwind +static-analyzer test xml"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -376,11 +376,6 @@ src_install() {
"/usr/lib/llvm/${SLOT}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {
diff --git a/sys-devel/clang/clang-13.0.1.9999.ebuild b/sys-devel/clang/clang-13.0.1.9999.ebuild
index 0a01ce5254cf..c9cdf6cd226b 100644
--- a/sys-devel/clang/clang-13.0.1.9999.ebuild
+++ b/sys-devel/clang/clang-13.0.1.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS=""
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +static-analyzer test xml kernel_FreeBSD"
+ doc llvm-libunwind +static-analyzer test xml"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -377,11 +377,6 @@ src_install() {
"/usr/lib/llvm/${SLOT}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {
diff --git a/sys-devel/clang/clang-13.0.1_rc1.ebuild b/sys-devel/clang/clang-13.0.1_rc1.ebuild
index 6d0789546970..cf79f953833e 100644
--- a/sys-devel/clang/clang-13.0.1_rc1.ebuild
+++ b/sys-devel/clang/clang-13.0.1_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS=""
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +static-analyzer test xml kernel_FreeBSD"
+ doc llvm-libunwind +static-analyzer test xml"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -377,11 +377,6 @@ src_install() {
"/usr/lib/llvm/${SLOT}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {
diff --git a/sys-devel/clang/clang-14.0.0.9999.ebuild b/sys-devel/clang/clang-14.0.0.9999.ebuild
index 26a32f2542ff..1de9a1a3a542 100644
--- a/sys-devel/clang/clang-14.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-14.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
KEYWORDS=""
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc llvm-libunwind +static-analyzer test xml kernel_FreeBSD"
+ doc llvm-libunwind +static-analyzer test xml"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
@@ -378,11 +378,6 @@ src_install() {
"/usr/lib/llvm/${SLOT}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {