summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-11.1.0.ebuild')
-rw-r--r--sys-devel/clang/clang-11.1.0.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/sys-devel/clang/clang-11.1.0.ebuild b/sys-devel/clang/clang-11.1.0.ebuild
index 844348ccef0f..70f90cdc03ee 100644
--- a/sys-devel/clang/clang-11.1.0.ebuild
+++ b/sys-devel/clang/clang-11.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,7 +24,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
IUSE="debug default-compiler-rt default-libcxx default-lld
- doc +static-analyzer test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
+ doc +static-analyzer test xml ${ALL_LLVM_TARGETS[*]}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
@@ -383,11 +383,6 @@ src_install() {
"/usr/lib/llvm/${SLOT%/*}/bin/${abi_chost}-${i}"
done
done
-
- # Remove unnecessary headers on FreeBSD, bug #417171
- if use kernel_FreeBSD; then
- rm "${ED}"/usr/lib/clang/${clang_full_version}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
- fi
}
multilib_src_install() {