summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-10-03 12:35:54 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-10-03 12:36:26 -0500
commit73187892e3b1ff195c127df43a63aac42fc43031 (patch)
tree017b1e30305ea5a28dc7bd3dc9cbf9119200052f /sys-apps/baselayout
parentdev-perl/Git-Wrapper: Fix missing dep on dev-vcs/git bug #633384 (diff)
downloadgentoo-73187892e3b1ff195c127df43a63aac42fc43031.tar.gz
gentoo-73187892e3b1ff195c127df43a63aac42fc43031.tar.bz2
gentoo-73187892e3b1ff195c127df43a63aac42fc43031.zip
sys-apps/baselayout: 2.4.1-r2: fix tmpfs warning
bug: https://bugs.gentoo.org/show_bug.cgi?id=633360 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-2.4.1-r2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild b/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild
index 0d17f0e8894a..2d2293456f95 100644
--- a/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild
+++ b/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild
@@ -224,10 +224,12 @@ pkg_postinst() {
if use kernel_linux; then
mkdir -p "${EROOT}"run
- if ! grep -qs "^tmpfs.*/run " "${ROOT}"proc/mounts ; then
- echo
- ewarn "You should reboot the system now to get /run mounted with tmpfs!"
- fi
+ local found
+ while read -r _ mountpoint fstype _; do
+ [[ ${mountpoint} = /run ]] && [[ ${fstype} = tmpfs ]] && found=1
+ done < "${ROOT}"proc/mounts
+ [[ -z ${found} ]] &&
+ ewarn "You should reboot now to get /run mounted with tmpfs!"
fi
for x in ${REPLACING_VERSIONS}; do