summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/baselayout/baselayout-2.4.1-r2.ebuild')
-rw-r--r--sys-apps/baselayout/baselayout-2.4.1-r2.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild b/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild
index 0d17f0e8894a..2d2293456f95 100644
--- a/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild
+++ b/sys-apps/baselayout/baselayout-2.4.1-r2.ebuild
@@ -224,10 +224,12 @@ pkg_postinst() {
if use kernel_linux; then
mkdir -p "${EROOT}"run
- if ! grep -qs "^tmpfs.*/run " "${ROOT}"proc/mounts ; then
- echo
- ewarn "You should reboot the system now to get /run mounted with tmpfs!"
- fi
+ local found
+ while read -r _ mountpoint fstype _; do
+ [[ ${mountpoint} = /run ]] && [[ ${fstype} = tmpfs ]] && found=1
+ done < "${ROOT}"proc/mounts
+ [[ -z ${found} ]] &&
+ ewarn "You should reboot now to get /run mounted with tmpfs!"
fi
for x in ${REPLACING_VERSIONS}; do