summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-27 00:22:49 +0000
committerSam James <sam@gentoo.org>2022-02-27 00:22:49 +0000
commit153fc1acbc29bd1b73420a52f63392b88f853fe2 (patch)
treecc467f907bd8c7f72fcb444a597ea435c74a90c2 /net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
parentnet-misc/turbovnc: do not build vncviewer if !java (diff)
downloadgentoo-153fc1acbc29bd1b73420a52f63392b88f853fe2.tar.gz
gentoo-153fc1acbc29bd1b73420a52f63392b88f853fe2.tar.bz2
gentoo-153fc1acbc29bd1b73420a52f63392b88f853fe2.zip
net-libs/zmqpp: update EAPI 7 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild')
-rw-r--r--net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild b/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..147cd25d9633
--- /dev/null
+++ b/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zeromq/zmqpp.git"
+else
+ SRC_URI="https://github.com/zeromq/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
+HOMEPAGE="https://github.com/zeromq/zmqpp"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="net-libs/zeromq[static-libs?]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-multilib-strict.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DIS_TRAVIS_CI_BUILD=OFF
+ -DZMQPP_BUILD_SHARED=ON
+ -DZMQPP_BUILD_STATIC=$(usex static-libs)
+ )
+
+ cmake_src_configure
+}