summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-27 00:22:49 +0000
committerSam James <sam@gentoo.org>2022-02-27 00:22:49 +0000
commit153fc1acbc29bd1b73420a52f63392b88f853fe2 (patch)
treecc467f907bd8c7f72fcb444a597ea435c74a90c2
parentnet-misc/turbovnc: do not build vncviewer if !java (diff)
downloadgentoo-153fc1acbc29bd1b73420a52f63392b88f853fe2.tar.gz
gentoo-153fc1acbc29bd1b73420a52f63392b88f853fe2.tar.bz2
gentoo-153fc1acbc29bd1b73420a52f63392b88f853fe2.zip
net-libs/zmqpp: update EAPI 7 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild (renamed from net-libs/zmqpp/zmqpp-4.2.0.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-libs/zmqpp/zmqpp-4.2.0.ebuild b/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
index 1394708a3dff..147cd25d9633 100644
--- a/net-libs/zmqpp/zmqpp-4.2.0.ebuild
+++ b/net-libs/zmqpp/zmqpp-4.2.0-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit cmake
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -10,7 +12,6 @@ else
SRC_URI="https://github.com/zeromq/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
-inherit cmake-utils
DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
HOMEPAGE="https://github.com/zeromq/zmqpp"
@@ -31,5 +32,5 @@ src_configure() {
-DZMQPP_BUILD_STATIC=$(usex static-libs)
)
- cmake-utils_src_configure
+ cmake_src_configure
}