summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-27 18:15:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-27 18:19:04 -0500
commit726ab52ed77898ea0936c5876f62ebd3d9c1a00a (patch)
tree065b28b2f17c2bbec6a341b65cd8f40cb7f4c53d /dev-python/publicsuffix/publicsuffix-2.20190205.ebuild
parentapp-admin/hddtemp: simplify and correct baseline init script (diff)
downloadgentoo-726ab52ed77898ea0936c5876f62ebd3d9c1a00a.tar.gz
gentoo-726ab52ed77898ea0936c5876f62ebd3d9c1a00a.tar.bz2
gentoo-726ab52ed77898ea0936c5876f62ebd3d9c1a00a.zip
dev-python/publicsuffix: adding for mailman2
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/publicsuffix/publicsuffix-2.20190205.ebuild')
-rw-r--r--dev-python/publicsuffix/publicsuffix-2.20190205.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/publicsuffix/publicsuffix-2.20190205.ebuild b/dev-python/publicsuffix/publicsuffix-2.20190205.ebuild
new file mode 100644
index 000000000000..6784ae27aea0
--- /dev/null
+++ b/dev-python/publicsuffix/publicsuffix-2.20190205.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Get a public suffix for a domain name using the Public Suffix List."
+HOMEPAGE="https://github.com/nexB/python-publicsuffix2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}2/${PN}2-${PV}.tar.gz"
+S="${WORKDIR}/${PN}2-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]"
+BDEPEND=""