summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/publicsuffix/Manifest1
-rw-r--r--dev-python/publicsuffix/metadata.xml14
-rw-r--r--dev-python/publicsuffix/publicsuffix-2.20190205.ebuild22
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/publicsuffix/Manifest b/dev-python/publicsuffix/Manifest
new file mode 100644
index 000000000000..69154581c960
--- /dev/null
+++ b/dev-python/publicsuffix/Manifest
@@ -0,0 +1 @@
+DIST publicsuffix2-2.20190205.tar.gz 84498 BLAKE2B 978b788aee4c40d687aff8d140e426658779bc913c846e420147e48f2837582991ff2900c7a483814c5b908c9771e04e04f41bf35795c2d2d1299c5513840e35 SHA512 359052a2b41f63be3f87b23605b5229424f2dcf06b5bd9e9b5f1988cf9df5171188b94d54ed0be37099d94afd6efe6cfa75be27aef262e6c5af0ded61dfc6258
diff --git a/dev-python/publicsuffix/metadata.xml b/dev-python/publicsuffix/metadata.xml
new file mode 100644
index 000000000000..1de14ee2fdcd
--- /dev/null
+++ b/dev-python/publicsuffix/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ This module allows you to get the public suffix of a domain name using the Public Suffix List from http://publicsuffix.org
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/publicsuffix/publicsuffix-2.20190205.ebuild b/dev-python/publicsuffix/publicsuffix-2.20190205.ebuild
new file mode 100644
index 000000000000..6784ae27aea0
--- /dev/null
+++ b/dev-python/publicsuffix/publicsuffix-2.20190205.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Get a public suffix for a domain name using the Public Suffix List."
+HOMEPAGE="https://github.com/nexB/python-publicsuffix2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}2/${PN}2-${PV}.tar.gz"
+S="${WORKDIR}/${PN}2-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]"
+BDEPEND=""