diff options
author | Ulrich Müller <ulm@gentoo.org> | 2020-01-27 21:37:00 +0100 |
---|---|---|
committer | Ulrich Müller <ulm@gentoo.org> | 2020-01-27 21:37:00 +0100 |
commit | aa6e1e365fff48b6e1e5470791f499a0589d39c3 (patch) | |
tree | d007482a18091072b8fbd33fa4346ac9e45e4070 /Makefile | |
parent | general-concepts/autotools/diagram.svg: Delete obsolete configure.in. (diff) | |
download | devmanual-aa6e1e365fff48b6e1e5470791f499a0589d39c3.tar.gz devmanual-aa6e1e365fff48b6e1e5470791f499a0589d39c3.tar.bz2 devmanual-aa6e1e365fff48b6e1e5470791f499a0589d39c3.zip |
Makefile: Add separate "build" target.
This is for the app-doc/devmanual[fallback] offline package, where we
don't have lunr.js and don't want to build documents.js.
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -7,7 +7,7 @@ HTMLS := $(subst text.xml,index.html,$(XMLS)) ECLASS_HTMLS := $(wildcard eclass-reference/*/index.html) IMAGES := $(patsubst %.svg,%.png,$(SVGS)) -all: prereq validate $(HTMLS) $(IMAGES) documents.js +all: prereq validate build documents.js prereq: @type rsvg-convert >/dev/null 2>&1 || \ @@ -23,6 +23,8 @@ prereq: { echo "media-fonts/open-sans is required" >&2;\ exit 1; } +build: $(HTMLS) $(IMAGES) + # We need to parse all the XMLs every time, not just the ones # that are newer than the target. This is because each search # document in devmanual gets a unique ID, which is used to @@ -68,4 +70,4 @@ tidy: $(HTMLS) $(ECLASS_HTMLS) clean: rm -f $(HTMLS) $(IMAGES) _documents.js documents.js -.PHONY: all prereq validate tidy clean +.PHONY: all prereq validate build tidy clean |