aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e7131ed..3fb4c52 100644
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@ HTMLS := $(subst text.xml,index.html,$(XMLS))
ECLASS_HTMLS := $(wildcard eclass-reference/*/index.html)
IMAGES := $(patsubst %.svg,%.png,$(SVGS))
-all: prereq validate $(HTMLS) $(IMAGES) documents.js
+all: prereq validate build documents.js
prereq:
@type rsvg-convert >/dev/null 2>&1 || \
@@ -23,6 +23,8 @@ prereq:
{ echo "media-fonts/open-sans is required" >&2;\
exit 1; }
+build: $(HTMLS) $(IMAGES)
+
# We need to parse all the XMLs every time, not just the ones
# that are newer than the target. This is because each search
# document in devmanual gets a unique ID, which is used to
@@ -68,4 +70,4 @@ tidy: $(HTMLS) $(ECLASS_HTMLS)
clean:
rm -f $(HTMLS) $(IMAGES) _documents.js documents.js
-.PHONY: all prereq validate tidy clean
+.PHONY: all prereq validate build tidy clean