summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/simplejson/ChangeLog9
-rw-r--r--dev-python/simplejson/simplejson-3.3.1.ebuild28
-rw-r--r--dev-python/simplejson/simplejson-3.3.2.ebuild28
-rw-r--r--dev-python/simplejson/simplejson-3.3.3.ebuild28
-rw-r--r--dev-python/simplejson/simplejson-3.4.0.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.4.1.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.5.0.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.5.1.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.5.2.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.5.3.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.6.0.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.6.2.ebuild30
-rw-r--r--dev-python/simplejson/simplejson-3.6.3.ebuild30
13 files changed, 8 insertions, 355 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index fcf3ea0a6d15..caefaac895ff 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.135 2014/08/31 14:23:22 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.136 2014/08/31 14:25:59 radhermit Exp $
+
+ 31 Aug 2014; Tim Harder <radhermit@gentoo.org> -simplejson-3.3.1.ebuild,
+ -simplejson-3.3.2.ebuild, -simplejson-3.3.3.ebuild, -simplejson-3.4.0.ebuild,
+ -simplejson-3.4.1.ebuild, -simplejson-3.5.0.ebuild, -simplejson-3.5.1.ebuild,
+ -simplejson-3.5.2.ebuild, -simplejson-3.5.3.ebuild, -simplejson-3.6.0.ebuild,
+ -simplejson-3.6.2.ebuild, -simplejson-3.6.3.ebuild:
+ Remove old.
*simplejson-3.6.3-r1 (31 Aug 2014)
diff --git a/dev-python/simplejson/simplejson-3.3.1.ebuild b/dev-python/simplejson/simplejson-3.3.1.ebuild
deleted file mode 100644
index 6852cb8ecded..000000000000
--- a/dev-python/simplejson/simplejson-3.3.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.3.1.ebuild,v 1.4 2014/03/31 20:36:54 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy pypy2_0 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.3.2.ebuild b/dev-python/simplejson/simplejson-3.3.2.ebuild
deleted file mode 100644
index c8562e2532aa..000000000000
--- a/dev-python/simplejson/simplejson-3.3.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.3.2.ebuild,v 1.4 2014/03/31 20:36:54 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy pypy2_0 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.3.3.ebuild b/dev-python/simplejson/simplejson-3.3.3.ebuild
deleted file mode 100644
index a24aea4819b8..000000000000
--- a/dev-python/simplejson/simplejson-3.3.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.3.3.ebuild,v 1.3 2014/04/02 21:08:06 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy pypy2_0 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.4.0.ebuild b/dev-python/simplejson/simplejson-3.4.0.ebuild
deleted file mode 100644
index 663c46d6d949..000000000000
--- a/dev-python/simplejson/simplejson-3.4.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.4.0.ebuild,v 1.3 2014/04/15 11:41:52 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy pypy2_0 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.4.1.ebuild b/dev-python/simplejson/simplejson-3.4.1.ebuild
deleted file mode 100644
index 43ad5e1b4b29..000000000000
--- a/dev-python/simplejson/simplejson-3.4.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.4.1.ebuild,v 1.1 2014/05/06 04:54:54 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.5.0.ebuild b/dev-python/simplejson/simplejson-3.5.0.ebuild
deleted file mode 100644
index aa88ac8efbaa..000000000000
--- a/dev-python/simplejson/simplejson-3.5.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.5.0.ebuild,v 1.1 2014/05/21 08:24:09 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.5.1.ebuild b/dev-python/simplejson/simplejson-3.5.1.ebuild
deleted file mode 100644
index f3668b813049..000000000000
--- a/dev-python/simplejson/simplejson-3.5.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.5.1.ebuild,v 1.1 2014/05/22 21:55:04 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2* ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.5.2.ebuild b/dev-python/simplejson/simplejson-3.5.2.ebuild
deleted file mode 100644
index a1c833700484..000000000000
--- a/dev-python/simplejson/simplejson-3.5.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.5.2.ebuild,v 1.1 2014/06/03 07:10:53 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.5.3.ebuild b/dev-python/simplejson/simplejson-3.5.3.ebuild
deleted file mode 100644
index 7a25dd772910..000000000000
--- a/dev-python/simplejson/simplejson-3.5.3.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.5.3.ebuild,v 1.1 2014/06/25 23:19:09 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.6.0.ebuild b/dev-python/simplejson/simplejson-3.6.0.ebuild
deleted file mode 100644
index da1eca912afc..000000000000
--- a/dev-python/simplejson/simplejson-3.6.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.0.ebuild,v 1.1 2014/07/21 17:11:44 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.6.2.ebuild b/dev-python/simplejson/simplejson-3.6.2.ebuild
deleted file mode 100644
index 2f40ed268a0b..000000000000
--- a/dev-python/simplejson/simplejson-3.6.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.2.ebuild,v 1.1 2014/08/20 10:54:02 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/simplejson/simplejson-3.6.3.ebuild b/dev-python/simplejson/simplejson-3.6.3.ebuild
deleted file mode 100644
index 973c1cbb5410..000000000000
--- a/dev-python/simplejson/simplejson-3.6.3.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.6.3.ebuild,v 1.1 2014/08/29 13:52:36 radhermit Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}