summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-12 04:41:02 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-12 04:41:02 +0000
commit5f3490fe8f8e5460e32496af5373e18b1a557beb (patch)
tree843a8d9fa79f9d33b858941a379ce32b1a178697 /sys-auth
parentDrop unused patches too. (diff)
downloadgentoo-2-5f3490fe8f8e5460e32496af5373e18b1a557beb.tar.gz
gentoo-2-5f3490fe8f8e5460e32496af5373e18b1a557beb.tar.bz2
gentoo-2-5f3490fe8f8e5460e32496af5373e18b1a557beb.zip
fully distutils-r1 compliant and sqlalchemy sucks
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog11
-rw-r--r--sys-auth/keystone/keystone-2012.2.4-r8.ebuild (renamed from sys-auth/keystone/keystone-2012.2.4-r7.ebuild)31
-rw-r--r--sys-auth/keystone/keystone-2013.1.3-r2.ebuild (renamed from sys-auth/keystone/keystone-2013.1.3-r1.ebuild)18
-rw-r--r--sys-auth/keystone/keystone-2013.1.9999.ebuild18
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild18
5 files changed, 54 insertions, 42 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index ba893f0d6602..5e255a5992a5 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.30 2013/09/11 16:01:38 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.31 2013/09/12 04:41:02 prometheanfire Exp $
+
+*keystone-2013.1.3-r2 (12 Sep 2013)
+*keystone-2012.2.4-r8 (12 Sep 2013)
+
+ 12 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +keystone-2012.2.4-r8.ebuild, +keystone-2013.1.3-r2.ebuild,
+ -keystone-2012.2.4-r7.ebuild, -keystone-2013.1.3-r1.ebuild,
+ keystone-2013.1.9999.ebuild, keystone-9999.ebuild:
+ fully distutils-r1 compliant and sqlalchemy sucks
*keystone-2012.2.4-r7 (11 Sep 2013)
*keystone-2013.1.3-r1 (11 Sep 2013)
diff --git a/sys-auth/keystone/keystone-2012.2.4-r7.ebuild b/sys-auth/keystone/keystone-2012.2.4-r8.ebuild
index 33d6a7cff4ea..0f796c7deb1d 100644
--- a/sys-auth/keystone/keystone-2012.2.4-r7.ebuild
+++ b/sys-auth/keystone/keystone-2012.2.4-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.4-r7.ebuild,v 1.1 2013/09/11 16:01:38 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.4-r8.ebuild,v 1.1 2013/09/12 04:41:02 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -24,23 +24,26 @@ REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#todo, seperate out rdepend via use flags
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
- dev-python/eventlet
- dev-python/greenlet
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
dev-python/iso8601[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/passlib
- dev-python/paste
- dev-python/pastedeploy
- dev-python/python-daemon
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/python-daemon[${PYTHON_USEDEP}]
dev-python/python-pam[${PYTHON_USEDEP}]
- dev-python/routes
- >=dev-python/sqlalchemy-migrate-0.7
- >=dev-python/webob-1.0.8
+ dev-python/routes[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.0.8[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- sqlite? ( dev-python/sqlalchemy[sqlite] )
- mysql? ( dev-python/sqlalchemy[mysql] )
- postgres? ( dev-python/sqlalchemy[postgres] )
- ldap? ( dev-python/python-ldap )"
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
# test? ( dev-python/Babel
# dev-python/decorator
# dev-python/eventlet
diff --git a/sys-auth/keystone/keystone-2013.1.3-r1.ebuild b/sys-auth/keystone/keystone-2013.1.3-r2.ebuild
index 6a6023ca7840..000e86ea6505 100644
--- a/sys-auth/keystone/keystone-2013.1.3-r1.ebuild
+++ b/sys-auth/keystone/keystone-2013.1.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.3-r1.ebuild,v 1.1 2013/09/11 16:01:37 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.3-r2.ebuild,v 1.1 2013/09/12 04:41:02 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -34,18 +34,18 @@ RDEPEND="${DEPEND}
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/python-daemon
+ dev-python/python-daemon[${PYTHON_USEDEP}]
>=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
dev-python/routes[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
- <=dev-python/sqlalchemy-0.7.9[sqlite] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
- <=dev-python/sqlalchemy-0.7.9[mysql] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
- <=dev-python/sqlalchemy-0.7.9[postgres] )
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
# test? ( dev-python/Babel
# dev-python/decorator
diff --git a/sys-auth/keystone/keystone-2013.1.9999.ebuild b/sys-auth/keystone/keystone-2013.1.9999.ebuild
index ed09be7232d4..7e45f49990fe 100644
--- a/sys-auth/keystone/keystone-2013.1.9999.ebuild
+++ b/sys-auth/keystone/keystone-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.9999.ebuild,v 1.3 2013/08/19 03:26:04 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.9999.ebuild,v 1.4 2013/09/12 04:41:02 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -35,18 +35,18 @@ RDEPEND="${DEPEND}
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/python-daemon
+ dev-python/python-daemon[${PYTHON_USEDEP}]
>=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
dev-python/routes[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
- <=dev-python/sqlalchemy-0.7.9[sqlite] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
- <=dev-python/sqlalchemy-0.7.9[mysql] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
- <=dev-python/sqlalchemy-0.7.9[postgres] )
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
# test? ( dev-python/Babel
# dev-python/decorator
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index e7d91aca79f8..22ff07b1f113 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.8 2013/04/11 07:17:05 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.9 2013/09/12 04:41:02 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -34,18 +34,18 @@ RDEPEND="${DEPEND}
dev-python/passlib[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/python-daemon
+ dev-python/python-daemon[${PYTHON_USEDEP}]
>=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
dev-python/routes[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
- sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
- <=dev-python/sqlalchemy-0.7.9[sqlite] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
- <=dev-python/sqlalchemy-0.7.9[mysql] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
- <=dev-python/sqlalchemy-0.7.9[postgres] )
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
# test? ( dev-python/Babel
# dev-python/decorator