summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-20 15:09:49 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-20 15:09:49 +0000
commit592fa588c5e7f92d0cfde8520075b9120215a566 (patch)
treed8d26e87aedb1bc68dfb80238961b8097ddd6223 /net-p2p/qbittorrent
parentforgot changelog (diff)
downloadgentoo-2-592fa588c5e7f92d0cfde8520075b9120215a566.tar.gz
gentoo-2-592fa588c5e7f92d0cfde8520075b9120215a566.tar.bz2
gentoo-2-592fa588c5e7f92d0cfde8520075b9120215a566.zip
Fix threads USE-flag check if boost >1.33, bug 174714
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog6
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild5
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild9
3 files changed, 13 insertions, 7 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 38dec9613638..04a3f42c369a 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.5 2007/04/13 13:57:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.6 2007/04/20 15:09:49 armin76 Exp $
+
+ 20 Apr 2007; Raúl Porcel <armin76@gentoo.org> qbittorrent-0.8.0.ebuild,
+ qbittorrent-0.9.2.ebuild:
+ Fix threads USE-flag check if boost >1.33, bug 174714
*qbittorrent-0.9.2 (13 Apr 2007)
diff --git a/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild b/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
index 1b4e15f7354f..f2ebc16e20e8 100644
--- a/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild,v 1.2 2007/02/13 20:52:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild,v 1.3 2007/04/20 15:09:49 armin76 Exp $
inherit eutils qt4
@@ -21,7 +21,8 @@ DEPEND=">=net-libs/rb_libtorrent-0.11
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! built_with_use "dev-libs/boost" threads && ! built_with_use "dev-libs/boost" threadsonly; then
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
eerror "dev-libs/boost has to be built with threads or threadsonly USE-flag."
die "Missing threads/threadsonly USE-flag for dev-libs/boost"
fi
diff --git a/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild b/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild
index 9cc0d1761830..8aea1b74882b 100644
--- a/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild,v 1.1 2007/04/13 13:57:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild,v 1.2 2007/04/20 15:09:49 armin76 Exp $
inherit eutils qt4
@@ -20,9 +20,10 @@ DEPEND=">=net-libs/rb_libtorrent-0.12_rc2
net-misc/curl"
pkg_setup() {
- if ! built_with_use "dev-libs/boost" threads && ! built_with_use "dev-libs/boost" threadsonly; then
- eerror "dev-libs/boost has to be built with threads or threadsonly USE-flag."
- die "Missing threads/threadsonly USE-flag for dev-libs/boost"
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
fi
}