summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild b/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
index 1b4e15f7354f..f2ebc16e20e8 100644
--- a/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild,v 1.2 2007/02/13 20:52:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild,v 1.3 2007/04/20 15:09:49 armin76 Exp $
inherit eutils qt4
@@ -21,7 +21,8 @@ DEPEND=">=net-libs/rb_libtorrent-0.11
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! built_with_use "dev-libs/boost" threads && ! built_with_use "dev-libs/boost" threadsonly; then
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
eerror "dev-libs/boost has to be built with threads or threadsonly USE-flag."
die "Missing threads/threadsonly USE-flag for dev-libs/boost"
fi