summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-01-02 00:36:52 +0000
committerBen de Groot <yngwin@gentoo.org>2009-01-02 00:36:52 +0000
commitdf4f1c274f238e96d6e22bf2b3d8db8dc8de6949 (patch)
treeedff5022d05844025681544fec82cdf68ffe90f6 /lxde-base/lxpanel
parent- relro is no longer needed in specs as it is a default (diff)
downloadgentoo-2-df4f1c274f238e96d6e22bf2b3d8db8dc8de6949.tar.gz
gentoo-2-df4f1c274f238e96d6e22bf2b3d8db8dc8de6949.tar.bz2
gentoo-2-df4f1c274f238e96d6e22bf2b3d8db8dc8de6949.zip
Adding patch to prevent sandbox failures, fixes bug 252774.
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-hh7 i686)
Diffstat (limited to 'lxde-base/lxpanel')
-rw-r--r--lxde-base/lxpanel/ChangeLog8
-rw-r--r--lxde-base/lxpanel/files/lxpanel-sandbox.patch27
-rw-r--r--lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild12
3 files changed, 43 insertions, 4 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index 4d78ab58ead2..5f0e340edb21 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for lxde-base/lxpanel
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.2 2008/12/07 18:55:04 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.3 2009/01/02 00:36:52 yngwin Exp $
+
+ 02 Jan 2009; Ben de Groot <yngwin@gentoo.org>
+ +files/lxpanel-sandbox.patch, lxpanel-0.3.8.1.ebuild:
+ Adding patch to prevent sandbox failures, fixes bug 252774.
07 Dec 2008; Ben de Groot <yngwin@gentoo.org> lxpanel-0.3.8.1.ebuild:
Add test restriction, see bug 249598.
diff --git a/lxde-base/lxpanel/files/lxpanel-sandbox.patch b/lxde-base/lxpanel/files/lxpanel-sandbox.patch
new file mode 100644
index 000000000000..739312b50bbf
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-sandbox.patch
@@ -0,0 +1,27 @@
+--- lxpanel/src/plugins/Makefile.am 2009-01-02 00:52:08.000000000 +0100
++++ lxpanel-fixed/src/plugins/Makefile.am 2009-01-02 01:15:48.000000000 +0100
+@@ -46,6 +46,4 @@
+ icon.xpm
+
+ install-exec-hook:
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.la
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.a
+- rm -f $(DESTDIR)$(libdir)/lxpanel/plugins/*.
++
+--- lxpanel/src/plugins/netstat/Makefile.am 2009-01-02 00:52:07.000000000 +0100
++++ lxpanel-fixed/src/plugins/netstat/Makefile.am 2009-01-02 01:18:50.000000000 +0100
+@@ -33,6 +33,5 @@
+ @LXPANEL_MODULE@
+
+ install-exec-hook:
+- rm -f "$(moduledir)\*.la" *.a
+
+ endif
+--- lxpanel/src/plugins/netstatus/Makefile.am 2009-01-02 00:52:08.000000000 +0100
++++ lxpanel-fixed/src/plugins/netstatus/Makefile.am 2009-01-02 01:19:08.000000000 +0100
+@@ -36,4 +36,4 @@
+ $(LXPANEL_MODULE)
+
+ install-exec-hook:
+- rm -f "$(moduledir)\*.la" *.a
++
diff --git a/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild b/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild
index 7d1f4752e411..a36c921110e4 100644
--- a/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild
+++ b/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild,v 1.2 2008/12/07 18:55:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild,v 1.3 2009/01/02 00:36:52 yngwin Exp $
EAPI="1"
+inherit eutils autotools
DESCRIPTION="Lightweight X11 desktop panel for LXDE"
HOMEPAGE="http://lxde.sf.net/"
@@ -24,6 +25,13 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
sys-devel/gettext"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-sandbox.patch
+ eautoreconf
+}
+
src_compile() {
econf $(use_enable alsa) \
$(use_enable wifi libiw) \