summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild')
-rw-r--r--lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild b/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild
index 7d1f4752e411..a36c921110e4 100644
--- a/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild
+++ b/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild,v 1.2 2008/12/07 18:55:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.3.8.1.ebuild,v 1.3 2009/01/02 00:36:52 yngwin Exp $
EAPI="1"
+inherit eutils autotools
DESCRIPTION="Lightweight X11 desktop panel for LXDE"
HOMEPAGE="http://lxde.sf.net/"
@@ -24,6 +25,13 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
sys-devel/gettext"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-sandbox.patch
+ eautoreconf
+}
+
src_compile() {
econf $(use_enable alsa) \
$(use_enable wifi libiw) \