summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 09:17:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 09:17:50 +0000
commit0848af6e43d45982c5535de139e7987a8fcf06e9 (patch)
tree50ca182b300b9752877ed631eaad23da7f24b7e4 /dev-util/ragel/ragel-6.8.ebuild
parentSmall fixup in new python code (diff)
downloadgentoo-2-0848af6e43d45982c5535de139e7987a8fcf06e9.tar.gz
gentoo-2-0848af6e43d45982c5535de139e7987a8fcf06e9.tar.bz2
gentoo-2-0848af6e43d45982c5535de139e7987a8fcf06e9.zip
Version bump and remove old. New ebuild uses autotools-utils.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-util/ragel/ragel-6.8.ebuild')
-rw-r--r--dev-util/ragel/ragel-6.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-6.8.ebuild b/dev-util/ragel/ragel-6.8.ebuild
new file mode 100644
index 000000000000..05a86395b0c7
--- /dev/null
+++ b/dev-util/ragel/ragel-6.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ragel-6.8.ebuild,v 1.1 2013/03/09 09:17:50 flameeyes Exp $
+
+EAPI=5
+
+inherit eutils autotools autotools-utils
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code."
+HOMEPAGE="http://www.complang.org/ragel/"
+SRC_URI="http://www.complang.org/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND=""
+
+# We need to get the txl language in Portage to have the tests :(
+RESTRICT=test
+
+DOCS=( ChangeLog CREDITS README TODO )
+
+src_prepare() {
+ sed -i -e '/CXXFLAGS/d' configure.in || die
+
+ eautoreconf
+}
+
+src_test() {
+ cd "${S}"/test
+ ./runtests.in || die
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim || die "doins ragel.vim failed"
+ fi
+}