summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 09:17:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 09:17:50 +0000
commit0848af6e43d45982c5535de139e7987a8fcf06e9 (patch)
tree50ca182b300b9752877ed631eaad23da7f24b7e4 /dev-util
parentSmall fixup in new python code (diff)
downloadgentoo-2-0848af6e43d45982c5535de139e7987a8fcf06e9.tar.gz
gentoo-2-0848af6e43d45982c5535de139e7987a8fcf06e9.tar.bz2
gentoo-2-0848af6e43d45982c5535de139e7987a8fcf06e9.zip
Version bump and remove old. New ebuild uses autotools-utils.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ragel/ChangeLog8
-rw-r--r--dev-util/ragel/ragel-6.8.ebuild (renamed from dev-util/ragel/ragel-6.6.ebuild)21
2 files changed, 20 insertions, 9 deletions
diff --git a/dev-util/ragel/ChangeLog b/dev-util/ragel/ChangeLog
index 2880c21f99cc..458955f1a3dc 100644
--- a/dev-util/ragel/ChangeLog
+++ b/dev-util/ragel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ragel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ChangeLog,v 1.61 2013/01/28 15:01:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ChangeLog,v 1.62 2013/03/09 09:17:50 flameeyes Exp $
+
+*ragel-6.8 (09 Mar 2013)
+
+ 09 Mar 2013; Diego E. Pettenò <flameeyes@gentoo.org> +ragel-6.8.ebuild,
+ -ragel-6.6.ebuild:
+ Version bump and remove old. New ebuild uses autotools-utils.
28 Jan 2013; Alexis Ballier <aballier@gentoo.org> ragel-6.7-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-util/ragel/ragel-6.6.ebuild b/dev-util/ragel/ragel-6.8.ebuild
index dbcb97fb8906..05a86395b0c7 100644
--- a/dev-util/ragel/ragel-6.6.ebuild
+++ b/dev-util/ragel/ragel-6.8.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ragel-6.6.ebuild,v 1.15 2011/04/23 17:35:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ragel-6.8.ebuild,v 1.1 2013/03/09 09:17:50 flameeyes Exp $
-EAPI="3"
+EAPI=5
+
+inherit eutils autotools autotools-utils
DESCRIPTION="Compiles finite state machines from regular languages into executable code."
HOMEPAGE="http://www.complang.org/ragel/"
@@ -10,7 +12,7 @@ SRC_URI="http://www.complang.org/ragel/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="vim-syntax"
DEPEND=""
@@ -19,8 +21,12 @@ RDEPEND=""
# We need to get the txl language in Portage to have the tests :(
RESTRICT=test
-src_configure() {
- econf --docdir="${EPREFIX}"/usr/share/doc/${PF} || die "econf failed"
+DOCS=( ChangeLog CREDITS README TODO )
+
+src_prepare() {
+ sed -i -e '/CXXFLAGS/d' configure.in || die
+
+ eautoreconf
}
src_test() {
@@ -29,8 +35,7 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc ChangeLog CREDITS README TODO || die "dodoc failed"
+ autotools-utils_src_install
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax