summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:37:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:37:59 +0000
commit182ab02b5e996b73cb7f154ba81a1e32baa5862e (patch)
treef5e432a9ecaeb8c1a3d65ef528493bba55a77a88 /dev-libs/dmalloc
parentadd inherit eutils (diff)
downloadgentoo-2-182ab02b5e996b73cb7f154ba81a1e32baa5862e.tar.gz
gentoo-2-182ab02b5e996b73cb7f154ba81a1e32baa5862e.tar.bz2
gentoo-2-182ab02b5e996b73cb7f154ba81a1e32baa5862e.zip
add inherit eutils
Diffstat (limited to 'dev-libs/dmalloc')
-rw-r--r--dev-libs/dmalloc/dmalloc-5.2.4.ebuild16
-rw-r--r--dev-libs/dmalloc/dmalloc-5.3.0.ebuild16
2 files changed, 16 insertions, 16 deletions
diff --git a/dev-libs/dmalloc/dmalloc-5.2.4.ebuild b/dev-libs/dmalloc/dmalloc-5.2.4.ebuild
index 00587b1ad9cf..d734e601686f 100644
--- a/dev-libs/dmalloc/dmalloc-5.2.4.ebuild
+++ b/dev-libs/dmalloc/dmalloc-5.2.4.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.2.4.ebuild,v 1.3 2004/02/22 20:02:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.2.4.ebuild,v 1.4 2004/04/16 02:34:16 vapier Exp $
-inherit debug
+inherit debug eutils
DESCRIPTION="A Debug Malloc Library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
HOMEPAGE="http://dmalloc.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-IUSE=""
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~x86 ~sparc"
+IUSE=""
DEPEND="virtual/glibc"
src_unpack() {
- unpack ${A} ; cd ${S}
-
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${P}-fpic.patch
}
diff --git a/dev-libs/dmalloc/dmalloc-5.3.0.ebuild b/dev-libs/dmalloc/dmalloc-5.3.0.ebuild
index cdd9a8300399..697aa3c1a4e2 100644
--- a/dev-libs/dmalloc/dmalloc-5.3.0.ebuild
+++ b/dev-libs/dmalloc/dmalloc-5.3.0.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.3.0.ebuild,v 1.1 2004/02/28 14:53:19 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.3.0.ebuild,v 1.2 2004/04/16 02:34:32 vapier Exp $
-inherit debug
+inherit debug eutils
DESCRIPTION="A Debug Malloc Library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
HOMEPAGE="http://dmalloc.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-IUSE=""
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
DEPEND="virtual/glibc"
src_unpack() {
- unpack ${A} ; cd ${S}
-
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${P}-fpic.patch
}
@@ -26,7 +26,7 @@ src_compile() {
emake all threads shlib tests || die "emake failed"
}
-src_install () {
+src_install() {
# install extra docs
dodoc ChangeLog INSTALL TODO NEWS NOTES README
dohtml Release.html dmalloc.html