summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/sr/sr-2.3.2.ebuild4
-rw-r--r--dev-lang/wml/wml-2.0.9.ebuild4
-rw-r--r--dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild9
-rw-r--r--dev-libs/csconv/csconv-11.4.1467.ebuild7
-rw-r--r--dev-libs/dmalloc/dmalloc-5.2.4.ebuild16
-rw-r--r--dev-libs/dmalloc/dmalloc-5.3.0.ebuild16
-rw-r--r--dev-libs/elfsh/elfsh-0.51_beta3.ebuild6
-rw-r--r--dev-libs/ffcall/ffcall-1.8d.ebuild16
-rw-r--r--dev-libs/gdome2/gdome2-0.8.0.ebuild11
-rw-r--r--dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild36
10 files changed, 60 insertions, 65 deletions
diff --git a/dev-lang/sr/sr-2.3.2.ebuild b/dev-lang/sr/sr-2.3.2.ebuild
index 0571a9824cbd..9ecdda612b8d 100644
--- a/dev-lang/sr/sr-2.3.2.ebuild
+++ b/dev-lang/sr/sr-2.3.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/sr/sr-2.3.2.ebuild,v 1.5 2004/03/14 02:40:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/sr/sr-2.3.2.ebuild,v 1.6 2004/04/16 02:33:00 vapier Exp $
+
+inherit eutils
DESCRIPTION="SR (Synchronizing Resources) is a language for writing concurrent programs"
HOMEPAGE="http://www.cs.arizona.edu/sr"
diff --git a/dev-lang/wml/wml-2.0.9.ebuild b/dev-lang/wml/wml-2.0.9.ebuild
index c99045615ed3..e7c2d1ce95ac 100644
--- a/dev-lang/wml/wml-2.0.9.ebuild
+++ b/dev-lang/wml/wml-2.0.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/wml/wml-2.0.9.ebuild,v 1.11 2004/04/15 21:34:13 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/wml/wml-2.0.9.ebuild,v 1.12 2004/04/16 02:33:15 vapier Exp $
-inherit fixheadtails
+inherit fixheadtails eutils
DESCRIPTION="Website META Language"
HOMEPAGE="http://www.engelschall.com/sw/wml/"
diff --git a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
index f00805ae3252..7c3b1c9cd1ef 100644
--- a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.11 2004/04/13 19:54:56 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.12 2004/04/16 02:33:31 vapier Exp $
inherit flag-o-matic
@@ -9,13 +9,12 @@ HOMEPAGE="http://sourceforge.net/projects/beecrypt"
SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
LICENSE="LGPL-2"
-KEYWORDS="x86 ppc sparc alpha amd64 ia64"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha amd64 ia64"
+IUSE="python"
DEPEND="python? ( >=dev-lang/python-2.2 )
- !<app-arch/rpm-4.2.1"
-
-IUSE="python"
+ !<app-arch/rpm-4.2.1"
src_unpack() {
unpack ${A}
diff --git a/dev-libs/csconv/csconv-11.4.1467.ebuild b/dev-libs/csconv/csconv-11.4.1467.ebuild
index b538a4fcbce4..44d20087d613 100644
--- a/dev-libs/csconv/csconv-11.4.1467.ebuild
+++ b/dev-libs/csconv/csconv-11.4.1467.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/csconv/csconv-11.4.1467.ebuild,v 1.3 2004/03/10 20:33:08 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/csconv/csconv-11.4.1467.ebuild,v 1.4 2004/04/16 02:33:44 vapier Exp $
-inherit iiimf
+inherit iiimf eutils
DESCRIPTION="A code conversion library for IIIMF"
@@ -12,13 +12,11 @@ KEYWORDS="~x86"
S="${WORKDIR}/${IMSDK}/lib/CSConv"
src_unpack() {
-
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.diff
}
src_compile() {
-
econf --prefix=/usr/lib/im \
--enable-optimize \
`use_enable debug` || die
@@ -27,7 +25,6 @@ src_compile() {
}
src_install() {
-
einstall prefix=${D}/usr/lib/im || die
cd ${WORKDIR}/${IMSDK}/doc/conv
diff --git a/dev-libs/dmalloc/dmalloc-5.2.4.ebuild b/dev-libs/dmalloc/dmalloc-5.2.4.ebuild
index 00587b1ad9cf..d734e601686f 100644
--- a/dev-libs/dmalloc/dmalloc-5.2.4.ebuild
+++ b/dev-libs/dmalloc/dmalloc-5.2.4.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.2.4.ebuild,v 1.3 2004/02/22 20:02:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.2.4.ebuild,v 1.4 2004/04/16 02:34:16 vapier Exp $
-inherit debug
+inherit debug eutils
DESCRIPTION="A Debug Malloc Library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
HOMEPAGE="http://dmalloc.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-IUSE=""
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~x86 ~sparc"
+IUSE=""
DEPEND="virtual/glibc"
src_unpack() {
- unpack ${A} ; cd ${S}
-
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${P}-fpic.patch
}
diff --git a/dev-libs/dmalloc/dmalloc-5.3.0.ebuild b/dev-libs/dmalloc/dmalloc-5.3.0.ebuild
index cdd9a8300399..697aa3c1a4e2 100644
--- a/dev-libs/dmalloc/dmalloc-5.3.0.ebuild
+++ b/dev-libs/dmalloc/dmalloc-5.3.0.ebuild
@@ -1,23 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.3.0.ebuild,v 1.1 2004/02/28 14:53:19 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.3.0.ebuild,v 1.2 2004/04/16 02:34:32 vapier Exp $
-inherit debug
+inherit debug eutils
DESCRIPTION="A Debug Malloc Library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
HOMEPAGE="http://dmalloc.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-IUSE=""
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
DEPEND="virtual/glibc"
src_unpack() {
- unpack ${A} ; cd ${S}
-
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${P}-fpic.patch
}
@@ -26,7 +26,7 @@ src_compile() {
emake all threads shlib tests || die "emake failed"
}
-src_install () {
+src_install() {
# install extra docs
dodoc ChangeLog INSTALL TODO NEWS NOTES README
dohtml Release.html dmalloc.html
diff --git a/dev-libs/elfsh/elfsh-0.51_beta3.ebuild b/dev-libs/elfsh/elfsh-0.51_beta3.ebuild
index b3ce607d8561..50b8ac6182d4 100644
--- a/dev-libs/elfsh/elfsh-0.51_beta3.ebuild
+++ b/dev-libs/elfsh/elfsh-0.51_beta3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfsh/elfsh-0.51_beta3.ebuild,v 1.2 2003/11/11 13:02:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfsh/elfsh-0.51_beta3.ebuild,v 1.3 2004/04/16 02:34:48 vapier Exp $
+
+inherit eutils
MY_PV=${PV/_beta/b}
S=${WORKDIR}/${PN}-${MY_PV}
diff --git a/dev-libs/ffcall/ffcall-1.8d.ebuild b/dev-libs/ffcall/ffcall-1.8d.ebuild
index 27c3f67e18f6..f1bc470ccfcf 100644
--- a/dev-libs/ffcall/ffcall-1.8d.ebuild
+++ b/dev-libs/ffcall/ffcall-1.8d.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.12 2004/02/15 12:08:52 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.13 2004/04/16 02:35:35 vapier Exp $
+
+inherit eutils
DESCRIPTION="foreign function call libraries"
-SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/directory/ffcall.html"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
# or in derivate works of GNUstep, the included parts of ffcall are
@@ -15,12 +17,10 @@ KEYWORDS="x86 sparc ~hppa ~alpha ~ppc"
DEPEND="virtual/glibc"
-
src_unpack() {
unpack ${A}
- #Fix hppa asm
- use hppa && (cd ${S}; epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz)
-
+ cd ${S}
+ use hppa && epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz
}
src_compile() {
@@ -28,13 +28,13 @@ src_compile() {
# alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
# doesn't work in the Makefile (29 Jan 2004 agriffis)
local cpu_setting
- [[ $ARCH == alpha ]] && cpu_setting='CPU=alpha'
+ [ "${ARCH}" == "alpha" ] && cpu_setting='CPU=alpha'
econf || die "./configure failed"
make ${cpu_setting} || die
}
-src_install () {
+src_install() {
dodoc ChangeLog NEWS README
dohtml avcall/avcall.html \
callback/callback.html \
diff --git a/dev-libs/gdome2/gdome2-0.8.0.ebuild b/dev-libs/gdome2/gdome2-0.8.0.ebuild
index cb82b857affd..e5091a159612 100644
--- a/dev-libs/gdome2/gdome2-0.8.0.ebuild
+++ b/dev-libs/gdome2/gdome2-0.8.0.ebuild
@@ -1,27 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdome2/gdome2-0.8.0.ebuild,v 1.3 2004/03/14 12:28:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdome2/gdome2-0.8.0.ebuild,v 1.4 2004/04/16 02:35:59 vapier Exp $
+
+inherit eutils
DESCRIPTION="The DOM C library for the GNOME project"
HOMEPAGE="http://gdome2.cs.unibo.it/"
SRC_URI="http://gdome2.cs.unibo.it/tarball/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc"
DEPEND=">=dev-libs/libxml2-2.4.21
=dev-libs/glib-1.2*"
-
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-libxml.patch
}
-# has the option of using glib-2 by using --enable-glib-2
src_compile() {
+ # has the option of using glib-2 by using --enable-glib-2
econf \
--with-html-dir=${D}/usr/share/doc || die "configure problem"
emake || die "compile problem"
@@ -29,5 +30,5 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die "install problem"
- dodoc AUTHORS ChangeLog COPYING* INSTALL MAINTAINERS README
+ dodoc AUTHORS ChangeLog INSTALL MAINTAINERS README
}
diff --git a/dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild b/dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild
index 91a40c169023..4c35746f69e2 100644
--- a/dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild
+++ b/dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild
@@ -1,37 +1,31 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild,v 1.4 2003/10/23 14:42:35 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmetadom/gmetadom-0.0.3-r3.ebuild,v 1.5 2004/04/16 02:37:59 vapier Exp $
-IUSE=""
+inherit eutils
DESCRIPTION="A library providing bindings for multiple languages of multiple C DOM implementations"
-HOMEPAGE="http://gmetadom.sf.net"
+HOMEPAGE="http://gmetadom.sourceforge.net/"
SRC_URI="mirror://sourceforge/gmetadom/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
-DEPEND="
- >=findlib-0.8
- >=libxslt-1.0.0
- >=gdome2-0.7.2"
-
-RDEPEND=">=gdome2-0.7.2"
-
-S="${WORKDIR}/${P}"
+DEPEND=">=dev-ml/findlib-0.8
+ >=dev-libs/libxslt-1.0.0
+ >=dev-libs/gdome2-0.7.2"
+RDEPEND=">=dev-libs/gdome2-0.7.2"
src_unpack() {
unpack ${A}
- cd ${S}/src/gdome_caml
- cp Makefile.am Makefile.am.orig
- sed -e 's:$(OCAMLFIND) install gdome2 META .libs/libmlgdome.so ;:$(OCAMLFIND) install -destdir=${DESTDIR}/usr/lib/ocaml/site-packages gdome2 META .libs/libmlgdome.so ;:' \
- Makefile.am.orig > Makefile.am.2
- sed -e 's:ocamllibdir = $(OCAML_LIB_PREFIX)/gdome2:ocamllibdir = $(OCAML_LIB_PREFIX)/site-packages/gdome2:' \
- Makefile.am.2 > Makefile.am.3
- sed -e 's:OCAMLINSTALLDIR = $(DESTDIR)$(OCAML_LIB_PREFIX)/gdome2:OCAMLINSTALLDIR = ${DESTDIR}$(OCAML_LIB_PREFIX)/site-packages/gdome2:' \
- Makefile.am.3 > Makefile.am
cd ${S}
+ sed -i \
+ -e 's:$(OCAMLFIND) install gdome2 META .libs/libmlgdome.so ;:$(OCAMLFIND) install -destdir=${DESTDIR}/usr/lib/ocaml/site-packages gdome2 META .libs/libmlgdome.so ;:' \
+ -e 's:ocamllibdir = $(OCAML_LIB_PREFIX)/gdome2:ocamllibdir = $(OCAML_LIB_PREFIX)/site-packages/gdome2:' \
+ -e 's:OCAMLINSTALLDIR = $(DESTDIR)$(OCAML_LIB_PREFIX)/gdome2:OCAMLINSTALLDIR = ${DESTDIR}$(OCAML_LIB_PREFIX)/site-packages/gdome2:' \
+ src/gdome_caml/Makefile.am
automake
epatch ${FILESDIR}/${P}-gcc3.diff
@@ -49,6 +43,6 @@ src_install() {
insinto /etc/env.d
doins 97gdome2
- dodoc AUTHORS BUGS ChangeLog COPYING HISTORY LICENSE NEWS README
+ dodoc AUTHORS BUGS ChangeLog HISTORY NEWS README
dohtml -r doc/html/*
}