summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-28 01:28:08 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-28 01:28:08 +0000
commitf87c870178fabcc4f72d54b04be360cf49ad4e91 (patch)
tree5079c7f61e8e3dded8f64b973d095465083ee552 /dev-lang
parentVersion bump. Bug #183375, by Martin Adler <martin.adler at gmail.com>. (diff)
downloadgentoo-2-f87c870178fabcc4f72d54b04be360cf49ad4e91.tar.gz
gentoo-2-f87c870178fabcc4f72d54b04be360cf49ad4e91.tar.bz2
gentoo-2-f87c870178fabcc4f72d54b04be360cf49ad4e91.zip
dev-lang/boo: added sed failure check
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/boo/ChangeLog6
-rw-r--r--dev-lang/boo/boo-0.7.5.2013-r1.ebuild11
-rw-r--r--dev-lang/boo/boo-0.7.6.2237-r1.ebuild9
3 files changed, 16 insertions, 10 deletions
diff --git a/dev-lang/boo/ChangeLog b/dev-lang/boo/ChangeLog
index 297a55c76465..c429c5afbdd9 100644
--- a/dev-lang/boo/ChangeLog
+++ b/dev-lang/boo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/boo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/ChangeLog,v 1.13 2007/06/27 20:38:41 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/ChangeLog,v 1.14 2007/06/28 01:28:08 jurek Exp $
+
+ 28 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> boo-0.7.5.2013-r1.ebuild,
+ boo-0.7.6.2237-r1.ebuild:
+ Added sed failure check
*boo-0.7.6.2237-r1 (27 Jun 2007)
*boo-0.7.5.2013-r1 (27 Jun 2007)
diff --git a/dev-lang/boo/boo-0.7.5.2013-r1.ebuild b/dev-lang/boo/boo-0.7.5.2013-r1.ebuild
index f075da326940..a1eebee3ca57 100644
--- a/dev-lang/boo/boo-0.7.5.2013-r1.ebuild
+++ b/dev-lang/boo/boo-0.7.5.2013-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.5.2013-r1.ebuild,v 1.1 2007/06/27 20:38:41 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.5.2013-r1.ebuild,v 1.2 2007/06/28 01:28:08 jurek Exp $
inherit mono fdo-mime eutils
DESCRIPTION="A wrist friendly language for the CLI"
HOMEPAGE="http://boo.codehaus.org/"
-SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.bz2"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/archive/${P}-src.tar.bz2"
LICENSE="BSD"
@@ -39,14 +39,15 @@ src_unpack() {
src_compile() {
# We no longer need to provide boo.lang (bug #163926)
sed -i -e 's#^.*<copy file="extras/boo.lang".*$##' \
- default.build
+ default.build || die "sed failed"
- nant -t:mono-1.0 -D:install.prefix=/usr || die
+ nant -t:mono-1.0 -D:install.prefix=/usr || die "build failed"
}
src_install() {
nant install \
- -D:install.destdir=${D} -t:mono-1.0 -D:install.prefix=/usr || die
+ -D:install.destdir=${D} -t:mono-1.0 -D:install.prefix=/usr ||
+ die "install failed"
use doc && dodoc docs/BooManifesto.sxw
diff --git a/dev-lang/boo/boo-0.7.6.2237-r1.ebuild b/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
index 0866ea8191f5..27cb04b1c73a 100644
--- a/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
+++ b/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.6.2237-r1.ebuild,v 1.1 2007/06/27 20:38:41 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.6.2237-r1.ebuild,v 1.2 2007/06/28 01:28:08 jurek Exp $
inherit mono fdo-mime eutils
@@ -22,14 +22,15 @@ DEPEND=">=dev-lang/mono-1.1.4
src_compile() {
# We no longer need to provide boo.lang (bug #163926)
sed -i -e 's#^.*<copy file="extras/boo.lang".*$##' \
- default.build
+ default.build || die "sed failed"
- nant -t:mono-2.0 -D:install.prefix=/usr || die
+ nant -t:mono-2.0 -D:install.prefix=/usr || die "build failed"
}
src_install() {
nant install \
- -D:install.destdir=${D} -t:mono-2.0 -D:install.prefix=/usr || die
+ -D:install.destdir=${D} -t:mono-2.0 -D:install.prefix=/usr ||
+ die "install failed"
use doc && dodoc docs/BooManifesto.sxw