summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/boo/boo-0.7.6.2237-r1.ebuild')
-rw-r--r--dev-lang/boo/boo-0.7.6.2237-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-lang/boo/boo-0.7.6.2237-r1.ebuild b/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
index 0866ea8191f5..27cb04b1c73a 100644
--- a/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
+++ b/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.6.2237-r1.ebuild,v 1.1 2007/06/27 20:38:41 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.6.2237-r1.ebuild,v 1.2 2007/06/28 01:28:08 jurek Exp $
inherit mono fdo-mime eutils
@@ -22,14 +22,15 @@ DEPEND=">=dev-lang/mono-1.1.4
src_compile() {
# We no longer need to provide boo.lang (bug #163926)
sed -i -e 's#^.*<copy file="extras/boo.lang".*$##' \
- default.build
+ default.build || die "sed failed"
- nant -t:mono-2.0 -D:install.prefix=/usr || die
+ nant -t:mono-2.0 -D:install.prefix=/usr || die "build failed"
}
src_install() {
nant install \
- -D:install.destdir=${D} -t:mono-2.0 -D:install.prefix=/usr || die
+ -D:install.destdir=${D} -t:mono-2.0 -D:install.prefix=/usr ||
+ die "install failed"
use doc && dodoc docs/BooManifesto.sxw