summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-20 23:24:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-20 23:24:23 +0000
commit23001af656ff9c2d219033ff1ccccb3aa142c52d (patch)
tree6abe73895fe86e828ca9f3bd662e744d4589cf28 /app-i18n/nkf
parentVersion Bump (diff)
downloadgentoo-2-23001af656ff9c2d219033ff1ccccb3aa142c52d.tar.gz
gentoo-2-23001af656ff9c2d219033ff1ccccb3aa142c52d.tar.bz2
gentoo-2-23001af656ff9c2d219033ff1ccccb3aa142c52d.zip
Quote ${S} uses, replace cjk useflag with linguas_ja, use doman to install the manpage, and respect LDFLAGS.
(Portage version: 2.1.2_rc3-r8)
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/ChangeLog6
-rw-r--r--app-i18n/nkf/nkf-2.0.7_beta1.ebuild23
2 files changed, 19 insertions, 10 deletions
diff --git a/app-i18n/nkf/ChangeLog b/app-i18n/nkf/ChangeLog
index be8e688fc11f..1c1afed7a719 100644
--- a/app-i18n/nkf/ChangeLog
+++ b/app-i18n/nkf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/nkf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.33 2006/10/21 13:30:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/ChangeLog,v 1.34 2006/12/20 23:24:23 flameeyes Exp $
+
+ 20 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> nkf-2.0.7_beta1.ebuild:
+ Quote ${S} uses, replace cjk useflag with linguas_ja, use doman to install
+ the manpage, and respect LDFLAGS.
21 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> files/nkf-python.patch:
Don't strip binary when linking, thanks to Patrick Lauer for reporting in
diff --git a/app-i18n/nkf/nkf-2.0.7_beta1.ebuild b/app-i18n/nkf/nkf-2.0.7_beta1.ebuild
index 854d031f6a92..32eaf0b19540 100644
--- a/app-i18n/nkf/nkf-2.0.7_beta1.ebuild
+++ b/app-i18n/nkf/nkf-2.0.7_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7_beta1.ebuild,v 1.1 2006/06/17 13:55:44 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7_beta1.ebuild,v 1.2 2006/12/20 23:24:23 flameeyes Exp $
inherit toolchain-funcs eutils perl-app distutils
@@ -13,17 +13,24 @@ SRC_URI="mirror://sourceforge.jp/nkf/20055/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="perl cjk"
+IUSE="perl linguas_ja"
#IUSE="${IUSE} python"
-DEPEND="virtual/libc"
+DEPEND=""
S="${WORKDIR}/${MY_P%%b*}"
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ "${S}/Makefile"
+}
+
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" nkf || die
if use perl; then
- cd ${S}/NKF.mod
+ cd "${S}/NKF.mod"
perl-module_src_compile
perl-module_src_test
fi
@@ -39,15 +46,13 @@ src_compile() {
src_install() {
dobin nkf || die
doman nkf.1
- if use cjk; then
- dodir /usr/share/man/ja/man1
- insinto /usr/share/man/ja/man1
+ if use linguas_ja; then
./nkf -e nkf.1j > nkf.1
- doins nkf.1
+ doman -i18n=ja nkf.1
fi
dodoc INSTALL* nkf.doc
if use perl; then
- cd ${S}/NKF.mod
+ cd "${S}/NKF.mod"
perl-module_src_install
fi
#if use python; then