summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/nkf/nkf-2.0.7_beta1.ebuild')
-rw-r--r--app-i18n/nkf/nkf-2.0.7_beta1.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/app-i18n/nkf/nkf-2.0.7_beta1.ebuild b/app-i18n/nkf/nkf-2.0.7_beta1.ebuild
index 854d031f6a92..32eaf0b19540 100644
--- a/app-i18n/nkf/nkf-2.0.7_beta1.ebuild
+++ b/app-i18n/nkf/nkf-2.0.7_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7_beta1.ebuild,v 1.1 2006/06/17 13:55:44 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/nkf/nkf-2.0.7_beta1.ebuild,v 1.2 2006/12/20 23:24:23 flameeyes Exp $
inherit toolchain-funcs eutils perl-app distutils
@@ -13,17 +13,24 @@ SRC_URI="mirror://sourceforge.jp/nkf/20055/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="perl cjk"
+IUSE="perl linguas_ja"
#IUSE="${IUSE} python"
-DEPEND="virtual/libc"
+DEPEND=""
S="${WORKDIR}/${MY_P%%b*}"
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
+ "${S}/Makefile"
+}
+
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" nkf || die
if use perl; then
- cd ${S}/NKF.mod
+ cd "${S}/NKF.mod"
perl-module_src_compile
perl-module_src_test
fi
@@ -39,15 +46,13 @@ src_compile() {
src_install() {
dobin nkf || die
doman nkf.1
- if use cjk; then
- dodir /usr/share/man/ja/man1
- insinto /usr/share/man/ja/man1
+ if use linguas_ja; then
./nkf -e nkf.1j > nkf.1
- doins nkf.1
+ doman -i18n=ja nkf.1
fi
dodoc INSTALL* nkf.doc
if use perl; then
- cd ${S}/NKF.mod
+ cd "${S}/NKF.mod"
perl-module_src_install
fi
#if use python; then