aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuriy Ustushenko <yoreek@yahoo.com>2012-03-10 14:00:20 +0200
committerYuriy Ustushenko <yoreek@yahoo.com>2012-03-10 14:00:20 +0200
commitd7bd080ea98c5781f9b944283e64940be64da1f4 (patch)
tree325563d6444f190400db1a57a9b2e59598681007
parentupdated the version of xsltproc module to v0.6 (diff)
downloadyoreek-d7bd080ea98c5781f9b944283e64940be64da1f4.tar.gz
yoreek-d7bd080ea98c5781f9b944283e64940be64da1f4.tar.bz2
yoreek-d7bd080ea98c5781f9b944283e64940be64da1f4.zip
updated the version of xsltproc module to v0.7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/nginx-1.0.10-r7.ebuild354
2 files changed, 356 insertions, 0 deletions
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 2bbe824..cee7324 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -10,6 +10,8 @@ DIST ngx_slowfs_cache-1.6.tar.gz 10972 RMD160 e1d10851db4a55fc465665caa3f6989d14
DIST ngx_upload_progress-0.8.3.tar.gz 16694 RMD160 b3c8835a270cda2224f5be35f1afb818821609b3 SHA1 0edae535d1efd50524d9947acaebe3979b06fcfb SHA256 f391da7fd1a89bd65e852182b6cbc746289cd10c83b211be18e703ff3e3986ae
DIST ngx_xsltproc-0.5.tar.gz 891256 RMD160 6108176eb77f23bea3f0a64d467fec5c02008217 SHA1 e33647c26a9a037ab047b8555a2f6e023c4efd76 SHA256 a0effc6500a4fcbcd494fda3d2094632b30a9ebcda12551a85442eb76d8a0970
DIST ngx_xsltproc-0.6.tar.gz 891356 RMD160 8cc3197218fa4e6ce8a631e5cc23ea0871b12a8f SHA1 922a42c88fd7ed2ef38f750777ce3991bafff5a6 SHA256 e09c4fb7ca0b21d4a6cacc2c422e455df021f7b789c7cd6eff09690eb05c4012
+DIST ngx_xsltproc-0.7.tar.gz 526153 RMD160 c62608bbbbe1d2017178ed21d30174448285740d SHA1 876b4b9c95c39ec1e65c4dfc9c3c4a40eb2ee9ce SHA256 e625c0f613a6b8fe4cd0fd9f7d37c22ba8c8a1283a8fb3d5752ead41ff7a471d
EBUILD nginx-1.0.10-r5.ebuild 11686 RMD160 4a7c58797b62ce98639aabbf0d075fde5b1511f9 SHA1 ad24de9492aad2aa9470bda09005fd56eba60d87 SHA256 f8a0e1324af4cb0d9ef0c1ba186e20e32c01d92c1c06d1de6e9c9341614101f6
EBUILD nginx-1.0.10-r6.ebuild 11686 RMD160 85d63077a5cda59c003b4a5fbafe4f3bf36e9a83 SHA1 0e7f078a3a0b1bf9b08f5b671c66de1575b166b6 SHA256 ba314b35c0f7390edf634b7592fba6552d8da645ef3602c944c9af7809d249c8
+EBUILD nginx-1.0.10-r7.ebuild 11686 RMD160 ee60320eaa3d2b44c144243fb4cac150c01419d6 SHA1 fbc670488536a2b5afe05fdf407ffe3f63fc90b0 SHA256 364d4479a808de9561eab400dfe8c9db6c8c95d69933a254f34ff900202c442d
MISC ChangeLog 50331 RMD160 837c73e65368056c9ac4720b1111ab758246e6dc SHA1 c6c2a10e3ff47befe0a9c3590d4505ed6d2e4bcb SHA256 b0a6c0095e45f9865fafd31e44485368c3de2909966480b4a763bc65872f8fe8
diff --git a/www-servers/nginx/nginx-1.0.10-r7.ebuild b/www-servers/nginx/nginx-1.0.10-r7.ebuild
new file mode 100644
index 0000000..d7e0187
--- /dev/null
+++ b/www-servers/nginx/nginx-1.0.10-r7.ebuild
@@ -0,0 +1,354 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.0.10.ebuild,v 1.5 2012/02/11 10:17:30 hollow Exp $
+
+EAPI="4"
+
+# Maintainer notes:
+# - http_rewrite-independent pcre-support makes sense for matching locations without an actual rewrite
+# - any http-module activates the main http-functionality and overrides USE=-http
+# - keep the following requirements in mind before adding external modules:
+# * alive upstream
+# * sane packaging
+# * builds cleanly
+# * does not need a patch for nginx core
+# - TODO: test the google-perftools module (included in vanilla tarball)
+
+# prevent perl-module from adding automagic perl DEPENDs
+GENTOO_DEPEND_ON_PERL="no"
+
+# http_uploadprogress (https://github.com/masterzen/nginx-upload-progress-module, BSD-2 license)
+HTTP_UPLOAD_PROGRESS_MODULE_PV="0.8.3"
+HTTP_UPLOAD_PROGRESS_MODULE_P="ngx_upload_progress-${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
+HTTP_UPLOAD_PROGRESS_MODULE_SHA1="c7c663f"
+HTTP_UPLOAD_PROGRESS_MODULE_URI="http://github.com/masterzen/nginx-upload-progress-module/tarball/v${HTTP_UPLOAD_PROGRESS_MODULE_PV}"
+
+# http_headers_more (http://github.com/agentzh/headers-more-nginx-module, BSD license)
+HTTP_HEADERS_MORE_MODULE_PV="0.15"
+HTTP_HEADERS_MORE_MODULE_P="ngx_http_headers_more-${HTTP_HEADERS_MORE_MODULE_PV}"
+HTTP_HEADERS_MORE_MODULE_SHA1="137855d"
+HTTP_HEADERS_MORE_MODULE_URI="http://github.com/agentzh/headers-more-nginx-module/tarball/v${HTTP_HEADERS_MORE_MODULE_PV}"
+
+# http_push (http://pushmodule.slact.net/, MIT license)
+HTTP_PUSH_MODULE_PV="0.692"
+HTTP_PUSH_MODULE_P="nginx_http_push_module-${HTTP_PUSH_MODULE_PV}"
+HTTP_PUSH_MODULE_URI="http://pushmodule.slact.net/downloads/${HTTP_PUSH_MODULE_P}.tar.gz"
+
+# http_cache_purge (http://labs.frickle.com/nginx_ngx_cache_purge/, BSD-2 license)
+HTTP_CACHE_PURGE_MODULE_PV="1.4"
+HTTP_CACHE_PURGE_MODULE_P="ngx_cache_purge-${HTTP_CACHE_PURGE_MODULE_PV}"
+HTTP_CACHE_PURGE_MODULE_URI="http://labs.frickle.com/files/${HTTP_CACHE_PURGE_MODULE_P}.tar.gz"
+
+# HTTP Upload module from Valery Kholodkov
+# (http://www.grid.net.ru/nginx/upload.en.html, BSD license)
+HTTP_UPLOAD_MODULE_PV="2.2.0"
+HTTP_UPLOAD_MODULE_P="nginx_upload_module-${HTTP_UPLOAD_MODULE_PV}"
+HTTP_UPLOAD_MODULE_URI="http://www.grid.net.ru/nginx/download/${HTTP_UPLOAD_MODULE_P}.tar.gz"
+
+# http_slowfs_cache (http://labs.frickle.com/nginx_ngx_slowfs_cache/, BSD-2 license)
+HTTP_SLOWFS_CACHE_MODULE_PV="1.6"
+HTTP_SLOWFS_CACHE_MODULE_P="ngx_slowfs_cache-${HTTP_SLOWFS_CACHE_MODULE_PV}"
+HTTP_SLOWFS_CACHE_MODULE_URI="http://labs.frickle.com/files/${HTTP_SLOWFS_CACHE_MODULE_P}.tar.gz"
+
+# http_xsltproc (http://github.com/yoreek/nginx-xsltproc-module/, BSD license)
+HTTP_XSLTPROC_MODULE_PV="0.7"
+HTTP_XSLTPROC_MODULE_P="ngx_xsltproc-${HTTP_XSLTPROC_MODULE_PV}"
+HTTP_XSLTPROC_MODULE_SHA1="9a4c10f"
+HTTP_XSLTPROC_MODULE_URI="https://github.com/yoreek/nginx-xsltproc-module/tarball/v${HTTP_XSLTPROC_MODULE_PV}"
+
+inherit eutils ssl-cert toolchain-funcs perl-module flag-o-matic
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+HOMEPAGE="http://nginx.org"
+SRC_URI="http://nginx.org/download/${P}.tar.gz
+ nginx_modules_http_upload_progress? ( ${HTTP_UPLOAD_PROGRESS_MODULE_URI} -> ${HTTP_UPLOAD_PROGRESS_MODULE_P}.tar.gz )
+ nginx_modules_http_headers_more? ( ${HTTP_HEADERS_MORE_MODULE_URI} -> ${HTTP_HEADERS_MORE_MODULE_P}.tar.gz )
+ nginx_modules_http_push? ( ${HTTP_PUSH_MODULE_URI} )
+ nginx_modules_http_cache_purge? ( ${HTTP_CACHE_PURGE_MODULE_URI} )
+ nginx_modules_http_upload? ( ${HTTP_UPLOAD_MODULE_URI} )
+ nginx_modules_http_slowfs_cache? ( ${HTTP_SLOWFS_CACHE_MODULE_URI} )
+ nginx_modules_http_xsltproc? ( ${HTTP_XSLTPROC_MODULE_URI} -> ${HTTP_XSLTPROC_MODULE_P}.tar.gz )"
+
+LICENSE="as-is BSD BSD-2 GPL-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+
+NGINX_MODULES_STD="access auth_basic autoindex browser charset empty_gif fastcgi
+geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi ssi
+split_clients upstream_ip_hash userid uwsgi"
+NGINX_MODULES_OPT="addition dav degradation flv geoip gzip_static image_filter
+mp4 perl random_index realip secure_link stub_status sub"
+NGINX_MODULES_MAIL="imap pop3 smtp"
+NGINX_MODULES_3RD="
+ http_upload_progress
+ http_headers_more
+ http_passenger
+ http_push
+ http_cache_purge
+ http_upload
+ http_slowfs_cache
+ http_xsltproc"
+
+IUSE="aio debug +http +http-cache ipv6 libatomic +pcre ssl vim-syntax +nginx_modules_http_xsltproc"
+
+for mod in $NGINX_MODULES_STD; do
+ IUSE="${IUSE} +nginx_modules_http_${mod}"
+done
+
+for mod in $NGINX_MODULES_OPT; do
+ IUSE="${IUSE} nginx_modules_http_${mod}"
+done
+
+for mod in $NGINX_MODULES_MAIL; do
+ IUSE="${IUSE} nginx_modules_mail_${mod}"
+done
+
+for mod in $NGINX_MODULES_3RD; do
+ IUSE="${IUSE} nginx_modules_${mod}"
+done
+
+CDEPEND="
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ http-cache? ( userland_GNU? ( dev-libs/openssl ) )
+ nginx_modules_http_geo? ( dev-libs/geoip )
+ nginx_modules_http_gzip? ( sys-libs/zlib )
+ nginx_modules_http_gzip_static? ( sys-libs/zlib )
+ nginx_modules_http_image_filter? ( media-libs/gd[jpeg,png] )
+ nginx_modules_http_perl? ( >=dev-lang/perl-5.8 )
+ nginx_modules_http_rewrite? ( >=dev-libs/libpcre-4.2 )
+ nginx_modules_http_secure_link? ( userland_GNU? ( dev-libs/openssl ) )
+ nginx_modules_http_xsltproc? ( dev-libs/libxml2 dev-libs/libxslt )"
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ arm? ( dev-libs/libatomic_ops )
+ libatomic? ( dev-libs/libatomic_ops )"
+PDEPEND="vim-syntax? ( app-vim/nginx-syntax )"
+
+pkg_setup() {
+ if use nginx_modules_http_passenger; then
+ einfo
+ einfo "Passenger support has been removed from the nginx ebuild to"
+ einfo "get rid of file collisions, its broken build system and"
+ einfo "incompatibilities between passenger 2 and 3."
+ einfo
+ einfo "Please switch to passenger-3 standalone or use the"
+ einfo "unicorn gem which provides a sane nginx-like architecture"
+ einfo "out of the box."
+ einfo
+ einfo "For more information on sane ruby deployments with"
+ einfo "passenger-3/unicorn go to:"
+ einfo
+ einfo "https://rvm.beginrescueend.com"
+ einfo
+ die "nginx_modules_http_passenger still in IUSE"
+ fi
+
+ ebegin "Creating nginx user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend $?
+
+ if use libatomic; then
+ ewarn "GCC 4.1+ features built-in atomic operations."
+ ewarn "Using libatomic_ops is only needed if using"
+ ewarn "a different compiler or a GCC prior to 4.1"
+ fi
+
+ if [[ -n $NGINX_ADD_MODULES ]]; then
+ ewarn "You are building custom modules via \$NGINX_ADD_MODULES!"
+ ewarn "This nginx installation is not supported!"
+ ewarn "Make sure you can reproduce the bug without those modules"
+ ewarn "_before_ reporting bugs."
+ fi
+
+ if use !http; then
+ ewarn "To actually disable all http-functionality you also have to disable"
+ ewarn "all nginx http modules."
+ fi
+}
+
+src_prepare() {
+ sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make
+}
+
+src_configure() {
+ local myconf= http_enabled= mail_enabled=
+
+ use aio && myconf+=" --with-file-aio --with-aio_module"
+ use debug && myconf+=" --with-debug"
+ use ipv6 && myconf+=" --with-ipv6"
+ use libatomic && myconf+=" --with-libatomic"
+ use pcre && myconf+=" --with-pcre"
+
+ # HTTP modules
+ for mod in $NGINX_MODULES_STD; do
+ if use nginx_modules_http_${mod}; then
+ http_enabled=1
+ else
+ myconf+=" --without-http_${mod}_module"
+ fi
+ done
+
+ for mod in $NGINX_MODULES_OPT; do
+ if use nginx_modules_http_${mod}; then
+ http_enabled=1
+ myconf+=" --with-http_${mod}_module"
+ fi
+ done
+
+ if use nginx_modules_http_fastcgi; then
+ myconf+=" --with-http_realip_module"
+ fi
+
+ # third-party modules
+ if use nginx_modules_http_upload_progress; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/masterzen-nginx-upload-progress-module-${HTTP_UPLOAD_PROGRESS_MODULE_SHA1}"
+ fi
+
+ if use nginx_modules_http_headers_more; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/agentzh-headers-more-nginx-module-${HTTP_HEADERS_MORE_MODULE_SHA1}"
+ fi
+
+ if use nginx_modules_http_push; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/${HTTP_PUSH_MODULE_P}"
+ fi
+
+ if use nginx_modules_http_cache_purge; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/${HTTP_CACHE_PURGE_MODULE_P}"
+ fi
+
+ if use nginx_modules_http_upload; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/${HTTP_UPLOAD_MODULE_P}"
+ fi
+
+ if use nginx_modules_http_slowfs_cache; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/${HTTP_SLOWFS_CACHE_MODULE_P}"
+ fi
+
+ if use nginx_modules_http_xsltproc; then
+ http_enabled=1
+ myconf+=" --add-module=${WORKDIR}/yoreek-nginx-xsltproc-module-${HTTP_XSLTPROC_MODULE_SHA1}"
+ fi
+
+ if use http || use http-cache; then
+ http_enabled=1
+ fi
+
+ if [ $http_enabled ]; then
+ use http-cache || myconf+=" --without-http-cache"
+ use ssl && myconf+=" --with-http_ssl_module"
+ else
+ myconf+=" --without-http --without-http-cache"
+ fi
+
+ # MAIL modules
+ for mod in $NGINX_MODULES_MAIL; do
+ if use nginx_modules_mail_${mod}; then
+ mail_enabled=1
+ else
+ myconf+=" --without-mail_${mod}_module"
+ fi
+ done
+
+ if [ $mail_enabled ]; then
+ myconf+=" --with-mail"
+ use ssl && myconf+=" --with-mail_ssl_module"
+ fi
+
+ # custom modules
+ for mod in $NGINX_ADD_MODULES; do
+ myconf+=" --add-module=${mod}"
+ done
+
+ # https://bugs.gentoo.org/286772
+ export LANG=C LC_ALL=C
+ tc-export CC
+
+ ./configure \
+ --prefix=/usr \
+ --sbin-path=/usr/sbin/nginx \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --lock-path=/var/lock/nginx.lock \
+ --user=${PN} --group=${PN} \
+ --with-cc-opt="-I${ROOT}usr/include" \
+ --with-ld-opt="-L${ROOT}usr/lib" \
+ --http-log-path=/var/log/${PN}/access_log \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --http-scgi-temp-path=/var/tmp/${PN}/scgi \
+ --http-uwsgi-temp-path=/var/tmp/${PN}/uwsgi \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ # https://bugs.gentoo.org/286772
+ export LANG=C LC_ALL=C
+ emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi,scgi,uwsgi}
+ keepdir /var/www/localhost/htdocs
+
+ dosbin objs/nginx
+ newinitd "${FILESDIR}"/nginx.initd nginx
+
+ cp "${FILESDIR}"/nginx.conf conf/nginx.conf
+ rm conf/win-utf conf/koi-win conf/koi-utf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/*
+
+ doman man/nginx.8
+ dodoc CHANGES* README
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/nginx.logrotate nginx
+
+ if use nginx_modules_http_perl; then
+ cd "${S}"/objs/src/http/modules/perl/
+ einstall DESTDIR="${D}" INSTALLDIRS=vendor || die "failed to install perl stuff"
+ fixlocalpod
+ fi
+
+ if use nginx_modules_http_push; then
+ docinto ${HTTP_PUSH_MODULE_P}
+ dodoc "${WORKDIR}"/${HTTP_PUSH_MODULE_P}/{changelog.txt,protocol.txt,README}
+ fi
+
+ if use nginx_modules_http_cache_purge; then
+ docinto ${HTTP_CACHE_PURGE_MODULE_P}
+ dodoc "${WORKDIR}"/${HTTP_CACHE_PURGE_MODULE_P}/{CHANGES,README.md,TODO.md}
+ fi
+
+ if use nginx_modules_http_upload; then
+ docinto ${HTTP_UPLOAD_MODULE_P}
+ dodoc "${WORKDIR}"/${HTTP_UPLOAD_MODULE_P}/{Changelog,README}
+ fi
+
+ if use nginx_modules_http_slowfs_cache; then
+ docinto ${HTTP_SLOWFS_CACHE_MODULE_P}
+ dodoc "${WORKDIR}"/${HTTP_SLOWFS_CACHE_MODULE_P}/{CHANGES,README}
+ fi
+}
+
+pkg_postinst() {
+ if use ssl; then
+ if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ install_cert /etc/ssl/${PN}/${PN}
+ chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
+ fi
+ fi
+}