summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/multi_links/multi_links-9999.ebuild')
-rw-r--r--www-plugins/multi_links/multi_links-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-plugins/multi_links/multi_links-9999.ebuild b/www-plugins/multi_links/multi_links-9999.ebuild
new file mode 100644
index 0000000..794462f
--- /dev/null
+++ b/www-plugins/multi_links/multi_links-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit mozilla-addon
+
+MOZ_ADDON_ID=13494
+DESCRIPTION="Firefox extension open, copy or bookmark multiple links at the same time"
+HOMEPAGE="http://www.grizzlyape.com/addons/multi-links/"
+SRC_URI="http://addons.mozilla.org/downloads/latest/${MOZ_ADDON_ID} -> ${P}.xpi"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+symlink_all_targets target_firefox target_firefox-bin"
+
+# symlink all possible target paths if this is set
+if use symlink_all_targets; then
+ MZA_TARGETS="firefox firefox-bin"
+else
+ use target_firefox && MZA_TARGETS+=" firefox"
+ use target_firefox-bin && MZA_TARGETS+=" firefox-bin"
+fi
+
+RDEPEND="
+ !symlink_all_targets? (
+ target_firefox? ( www-client/firefox )
+ target_firefox-bin? ( www-client/firefox-bin )
+ )"
+
+pkg_postinst() {
+ ewarn "This ebuild installs the latest STABLE version !"
+ ewarn "It is used by the maintainer to check for new versions ..."
+}