summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/lirc/files')
-rw-r--r--app-misc/lirc/files/irexec-confd9
-rwxr-xr-xapp-misc/lirc/files/irexec-initd-0.8.6-r328
-rw-r--r--app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch26
-rw-r--r--app-misc/lirc/files/lirc-0.8.4-portaudio_check.patch18
-rw-r--r--app-misc/lirc/files/lirc-0.8.6-kernel_2.6.33_fix.patch269
-rw-r--r--app-misc/lirc/files/lirc_i2c_r1.70_to_r1.72.patch76
-rw-r--r--app-misc/lirc/files/lircd-0.8.639
-rw-r--r--app-misc/lirc/files/lircd.conf.210
-rwxr-xr-xapp-misc/lirc/files/lircmd20
-rw-r--r--app-misc/lirc/files/modprobed.lirc22
10 files changed, 0 insertions, 517 deletions
diff --git a/app-misc/lirc/files/irexec-confd b/app-misc/lirc/files/irexec-confd
deleted file mode 100644
index 48eb8dd..0000000
--- a/app-misc/lirc/files/irexec-confd
+++ /dev/null
@@ -1,9 +0,0 @@
-# Options to pass to the irexec process
-IREXEC_OPTS="/etc/lircrc"
-
-# User to execute irexec as.
-# Warning: Running irexec as root can open security holes
-#IREXEC_USER="root"
-
-# Use this to disable the warning printed when starting irexec as root
-# IREXEC_DISABLE_ROOT_WARNING=yes
diff --git a/app-misc/lirc/files/irexec-initd-0.8.6-r3 b/app-misc/lirc/files/irexec-initd-0.8.6-r3
deleted file mode 100755
index 567322a..0000000
--- a/app-misc/lirc/files/irexec-initd-0.8.6-r3
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/sbin/runscript
-# Copyright 2003 Martin Hierling <mad@cc.fh-lippe.de>
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/files/irexec-initd-0.8.6-r2,v 1.1 2009/11/15 10:04:21 zzam Exp $
-
-: ${IREXEC_USER:=root}
-
-depend() {
- need lirc
-}
-
-start() {
- if [ "x${IREXEC_USER}" = "xroot" -a "x${IREXEC_DISABLE_ROOT_WARNING}" != "xyes" ]; then
- ewarn "Warning: Running irexec as root can open security holes"
- fi
-
- ebegin "Starting irexec"
- start-stop-daemon --start --chuid ${IREXEC_USER} --user ${IREXEC_USER} --chdir / \
- --exec /usr/bin/irexec -- --daemon ${IREXEC_OPTS}
- eend $? "Failed to start irexec."
-}
-
-stop() {
- ebegin "Stopping irexec"
- start-stop-daemon --stop --exec /usr/bin/irexec --user ${IREXEC_USER}
- eend $? "Failed to stop irexec."
-}
-
diff --git a/app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch b/app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch
deleted file mode 100644
index 66527bc..0000000
--- a/app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.c.orig 2005-10-29 08:18:53.000000000 -0600
-+++ lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.c 2006-04-01 14:31:05.000000000 -0700
-@@ -147,8 +147,9 @@
- /* init strings */
- #define USB_OUTLEN 7
-
--static char init1[] = {0x01, 0x00, 0x20, 0x14};
--static char init2[] = {0x01, 0x00, 0x20, 0x14, 0x20, 0x20, 0x20};
-+static char init1[] = {0x80, 0x05, 0x1b, 0x15, 0x14, 0x20, 0x24, 0x15};
-+static char init2[] = {0x83, 0x03};
-+static char init3[] = {0x84, 0xd7, 0x020};
-
- struct in_endpt {
- /* inner link in list of endpoints for the remote specified by ir */
-@@ -1034,8 +1034,9 @@
- usb_sndintpipe(ir->usbdev, oep->ep->bEndpointAddress), oep->buf,
- USB_OUTLEN, usb_remote_send, oep, oep->ep->bInterval);
-
-- send_packet(oep, 0x8004, init1);
-- send_packet(oep, 0x8007, init2);
-+ send_packet(oep, 0x8007, init1);
-+ send_packet(oep, 0x8002, init2);
-+ send_packet(oep, 0x8003, init3);
- }
- }
-
diff --git a/app-misc/lirc/files/lirc-0.8.4-portaudio_check.patch b/app-misc/lirc/files/lirc-0.8.4-portaudio_check.patch
deleted file mode 100644
index 36f5f36..0000000
--- a/app-misc/lirc/files/lirc-0.8.4-portaudio_check.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Portaudio is only needed for LIRC_DEVICES=audio, so not checking for Portaudio when the device is disabled will prevent automagic dependencies.
---- configure.ac.orig 2009-03-13 10:02:50.000000000 +0100
-+++ configure.ac 2009-03-13 10:04:00.000000000 +0100
-@@ -336,14 +336,6 @@
- AC_DEFINE(HAVE_LIBIRMAN_SW)
- possible_drivers="${possible_drivers} (irman_sw)"
- )
--dnl audio driver requires PortAudio library installed and some linker flags
--AC_CHECK_HEADERS(portaudio.h,[
-- AC_CHECK_LIB(portaudio, Pa_Initialize,[
-- AC_DEFINE(HAVE_LIBPORTAUDIO)
-- possible_drivers="${possible_drivers} (audio)"
-- ],,${portaudio_lib_other}
-- )]
--)
- dnl audio_alsa driver requires ALSA library installed and some linker flags
- have_alsa=no
- AC_CHECK_HEADERS(alsa/asoundlib.h,[
diff --git a/app-misc/lirc/files/lirc-0.8.6-kernel_2.6.33_fix.patch b/app-misc/lirc/files/lirc-0.8.6-kernel_2.6.33_fix.patch
deleted file mode 100644
index e933e64..0000000
--- a/app-misc/lirc/files/lirc-0.8.6-kernel_2.6.33_fix.patch
+++ /dev/null
@@ -1,269 +0,0 @@
---- drivers/lirc_dev/lirc_dev.h 2009/03/15 09:34:00 1.37
-+++ drivers/lirc_dev/lirc_dev.h 2010/01/23 16:28:07 1.39
-@@ -4,7 +4,7 @@
- * (L) by Artur Lipowski <alipowski@interia.pl>
- * This code is licensed under GNU GPL
- *
-- * $Id: lirc_dev.h,v 1.37 2009/03/15 09:34:00 lirc Exp $
-+ * $Id: lirc_dev.h,v 1.39 2010/01/23 16:28:07 lirc Exp $
- *
- */
-
-@@ -30,14 +30,19 @@
-
- struct lirc_buffer {
- wait_queue_head_t wait_poll;
-- spinlock_t lock;
-+ spinlock_t fifo_lock;
- unsigned int chunk_size;
- unsigned int size; /* in chunks */
- /* Using chunks instead of bytes pretends to simplify boundary checking
- * And should allow for some performance fine tunning later */
- #ifdef LIRC_HAVE_KFIFO
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
- struct kfifo *fifo;
- #else
-+ struct kfifo fifo;
-+ u8 fifo_initialized;
-+#endif
-+#else
- unsigned int fill; /* in chunks */
- int head, tail; /* in chunks */
- unsigned char *data;
-@@ -47,12 +52,12 @@
- static inline void lirc_buffer_lock(struct lirc_buffer *buf,
- unsigned long *flags)
- {
-- spin_lock_irqsave(&buf->lock, *flags);
-+ spin_lock_irqsave(&buf->fifo_lock, *flags);
- }
- static inline void lirc_buffer_unlock(struct lirc_buffer *buf,
- unsigned long *flags)
- {
-- spin_unlock_irqrestore(&buf->lock, *flags);
-+ spin_unlock_irqrestore(&buf->fifo_lock, *flags);
- }
- static inline void _lirc_buffer_clear(struct lirc_buffer *buf)
- {
-@@ -64,10 +69,21 @@
- static inline void lirc_buffer_clear(struct lirc_buffer *buf)
- {
- #ifdef LIRC_HAVE_KFIFO
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
- if (buf->fifo)
- kfifo_reset(buf->fifo);
- #else
- unsigned long flags;
-+
-+ if (buf->fifo_initialized) {
-+ spin_lock_irqsave(&buf->fifo_lock, flags);
-+ kfifo_reset(&buf->fifo);
-+ spin_unlock_irqrestore(&buf->fifo_lock, flags);
-+ }
-+#endif
-+#else
-+ unsigned long flags;
-+
- lirc_buffer_lock(buf, &flags);
- _lirc_buffer_clear(buf);
- lirc_buffer_unlock(buf, &flags);
-@@ -77,31 +93,47 @@
- unsigned int chunk_size,
- unsigned int size)
- {
-+ int ret = 0;
-+
- init_waitqueue_head(&buf->wait_poll);
-- spin_lock_init(&buf->lock);
-+ spin_lock_init(&buf->fifo_lock);
- #ifndef LIRC_HAVE_KFIFO
- _lirc_buffer_clear(buf);
- #endif
- buf->chunk_size = chunk_size;
- buf->size = size;
- #ifdef LIRC_HAVE_KFIFO
-- buf->fifo = kfifo_alloc(size*chunk_size, GFP_KERNEL, &buf->lock);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
-+ buf->fifo = kfifo_alloc(size*chunk_size, GFP_KERNEL, &buf->fifo_lock);
- if (!buf->fifo)
- return -ENOMEM;
- #else
-+ ret = kfifo_alloc(&buf->fifo, size * chunk_size, GFP_KERNEL);
-+ if (ret == 0)
-+ buf->fifo_initialized = 1;
-+#endif
-+#else
- buf->data = kmalloc(size*chunk_size, GFP_KERNEL);
- if (buf->data == NULL)
- return -ENOMEM;
- memset(buf->data, 0, size*chunk_size);
- #endif
-- return 0;
-+
-+ return ret;
- }
- static inline void lirc_buffer_free(struct lirc_buffer *buf)
- {
- #ifdef LIRC_HAVE_KFIFO
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
- if (buf->fifo)
- kfifo_free(buf->fifo);
- #else
-+ if (buf->fifo_initialized) {
-+ kfifo_free(&buf->fifo);
-+ buf->fifo_initialized = 0;
-+ }
-+#endif
-+#else
- kfree(buf->data);
- buf->data = NULL;
- buf->head = 0;
-@@ -111,6 +143,25 @@
- buf->size = 0;
- #endif
- }
-+
-+#ifdef LIRC_HAVE_KFIFO
-+static inline int lirc_buffer_len(struct lirc_buffer *buf)
-+{
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
-+ return kfifo_len(buf->fifo);
-+#else
-+ int len;
-+ unsigned long flags;
-+
-+ spin_lock_irqsave(&buf->fifo_lock, flags);
-+ len = kfifo_len(&buf->fifo);
-+ spin_unlock_irqrestore(&buf->fifo_lock, flags);
-+
-+ return len;
-+#endif
-+}
-+#endif
-+
- #ifndef LIRC_HAVE_KFIFO
- static inline int _lirc_buffer_full(struct lirc_buffer *buf)
- {
-@@ -120,7 +171,7 @@
- static inline int lirc_buffer_full(struct lirc_buffer *buf)
- {
- #ifdef LIRC_HAVE_KFIFO
-- return kfifo_len(buf->fifo) == buf->size * buf->chunk_size;
-+ return lirc_buffer_len(buf) == buf->size * buf->chunk_size;
- #else
- unsigned long flags;
- int ret;
-@@ -139,7 +190,7 @@
- static inline int lirc_buffer_empty(struct lirc_buffer *buf)
- {
- #ifdef LIRC_HAVE_KFIFO
-- return !kfifo_len(buf->fifo);
-+ return !lirc_buffer_len(buf);
- #else
- unsigned long flags;
- int ret;
-@@ -158,7 +209,7 @@
- static inline int lirc_buffer_available(struct lirc_buffer *buf)
- {
- #ifdef LIRC_HAVE_KFIFO
-- return buf->size - (kfifo_len(buf->fifo) / buf->chunk_size);
-+ return buf->size - (lirc_buffer_len(buf) / buf->chunk_size);
- #else
- unsigned long flags;
- int ret;
-@@ -177,21 +228,30 @@
- buf->fill -= 1;
- }
- #endif
--static inline void lirc_buffer_read(struct lirc_buffer *buf,
-- unsigned char *dest)
-+static inline unsigned int lirc_buffer_read(struct lirc_buffer *buf,
-+ unsigned char *dest)
- {
-+ unsigned int ret = 0;
-+
- #ifdef LIRC_HAVE_KFIFO
-- if (kfifo_len(buf->fifo) >= buf->chunk_size)
-- kfifo_get(buf->fifo, dest, buf->chunk_size);
-+ if (lirc_buffer_len(buf) >= buf->chunk_size)
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
-+ ret = kfifo_get(buf->fifo, dest, buf->chunk_size);
-+#else
-+ ret = kfifo_out_locked(&buf->fifo, dest, buf->chunk_size,
-+ &buf->fifo_lock);
-+#endif
- #else
- unsigned long flags;
- lirc_buffer_lock(buf, &flags);
- _lirc_buffer_read_1(buf, dest);
- lirc_buffer_unlock(buf, &flags);
- #endif
-+
-+ return ret;
- }
- #ifndef LIRC_HAVE_KFIFO
--static inline void _lirc_buffer_write_1(struct lirc_buffer *buf,
-+static inline _lirc_buffer_write_1(struct lirc_buffer *buf,
- unsigned char *orig)
- {
- memcpy(&buf->data[buf->tail*buf->chunk_size], orig, buf->chunk_size);
-@@ -199,17 +259,26 @@
- buf->fill++;
- }
- #endif
--static inline void lirc_buffer_write(struct lirc_buffer *buf,
-- unsigned char *orig)
-+static inline unsigned int lirc_buffer_write(struct lirc_buffer *buf,
-+ unsigned char *orig)
- {
-+ unsigned int ret = 0;
-+
- #ifdef LIRC_HAVE_KFIFO
-- kfifo_put(buf->fifo, orig, buf->chunk_size);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
-+ ret = kfifo_put(buf->fifo, orig, buf->chunk_size);
-+#else
-+ ret = kfifo_in_locked(&buf->fifo, orig, buf->chunk_size,
-+ &buf->fifo_lock);
-+#endif
- #else
- unsigned long flags;
- lirc_buffer_lock(buf, &flags);
- _lirc_buffer_write_1(buf, orig);
- lirc_buffer_unlock(buf, &flags);
- #endif
-+
-+ return ret;
- }
- #ifndef LIRC_HAVE_KFIFO
- static inline void _lirc_buffer_write_n(struct lirc_buffer *buf,
-@@ -234,17 +303,26 @@
- buf->fill += count;
- }
- #endif
--static inline void lirc_buffer_write_n(struct lirc_buffer *buf,
-- unsigned char *orig, int count)
-+static inline unsigned int lirc_buffer_write_n(struct lirc_buffer *buf,
-+ unsigned char *orig, int count)
- {
-+ unsigned int ret = 0;
-+
- #ifdef LIRC_HAVE_KFIFO
-- kfifo_put(buf->fifo, orig, count * buf->chunk_size);
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 33)
-+ ret = kfifo_put(buf->fifo, orig, count * buf->chunk_size);
-+#else
-+ ret = kfifo_in_locked(&buf->fifo, orig, count * buf->chunk_size,
-+ &buf->fifo_lock);
-+#endif
- #else
- unsigned long flags;
- lirc_buffer_lock(buf, &flags);
- _lirc_buffer_write_n(buf, orig, count);
- lirc_buffer_unlock(buf, &flags);
- #endif
-+
-+ return ret;
- }
-
- struct lirc_driver {
diff --git a/app-misc/lirc/files/lirc_i2c_r1.70_to_r1.72.patch b/app-misc/lirc/files/lirc_i2c_r1.70_to_r1.72.patch
deleted file mode 100644
index 7dc7cd5..0000000
--- a/app-misc/lirc/files/lirc_i2c_r1.70_to_r1.72.patch
+++ /dev/null
@@ -1,76 +0,0 @@
---- drivers/lirc_i2c/lirc_i2c.c 2009/08/30 16:59:53 1.70
-+++ drivers/lirc_i2c/lirc_i2c.c 2009/12/28 15:29:03 1.72
-@@ -1,4 +1,4 @@
--/* $Id: lirc_i2c.c,v 1.70 2009/08/30 16:59:53 jarodwilson Exp $ */
-+/* $Id: lirc_i2c.c,v 1.72 2009/12/28 15:29:03 jarodwilson Exp $ */
-
- /*
- * lirc_i2c.c
-@@ -399,8 +399,8 @@
- .name = "i2c ir driver",
- },
- #endif
-- .id = I2C_DRIVERID_EXP3, /* FIXME */
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 31)
-+ .id = I2C_DRIVERID_EXP3, /* FIXME */
- .attach_adapter = ir_probe,
- .detach_client = ir_remove,
- #else
-@@ -492,20 +492,23 @@
- ir->l.add_to_buf = add_to_buf_pv951;
- break;
- case 0x71:
--#ifdef I2C_HW_B_CX2341X
-- if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848) ||
-- adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2341X)) {
--#else
-- if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848)) {
-+
-+
-+
-+#ifdef I2C_HW_B_CX2388x
-+ /* Leadtek Winfast PVR2000 or Hauppauge HVR-1300 */
-+ if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2388x))
-+ strlcpy(ir->c.name, "Hauppauge HVR1300", I2C_NAME_SIZE);
-+ else
- #endif
-+ {
- /*
- * The PVR150 IR receiver uses the same protocol as
- * other Hauppauge cards, but the data flow is
- * different, so we need to deal with it by its own.
- */
- strlcpy(ir->c.name, "Hauppauge PVR150", I2C_NAME_SIZE);
-- } else /* I2C_HW_B_CX2388x */
-- strlcpy(ir->c.name, "Hauppauge HVR1300", I2C_NAME_SIZE);
-+ }
- ir->l.code_length = 13;
- ir->l.add_to_buf = add_to_buf_haup_pvr150;
- break;
-@@ -516,19 +519,18 @@
- break;
- case 0x18:
- case 0x1a:
--#ifdef I2C_HW_B_CX2341X
-- if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848) ||
-- adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2341X)) {
-+#ifdef I2C_HW_B_CX2388x
-+ if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2388x)) {
-+ strlcpy(ir->c.name, "Leadtek IR", I2C_NAME_SIZE);
-+ ir->l.code_length = 8;
-+ ir->l.add_to_buf = add_to_buf_pvr2000;
-+ } else {
- #else
-- if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848)) {
-+ {
- #endif
- strlcpy(ir->c.name, "Hauppauge IR", I2C_NAME_SIZE);
- ir->l.code_length = 13;
- ir->l.add_to_buf = add_to_buf_haup;
-- } else { /* I2C_HW_B_CX2388x */
-- strlcpy(ir->c.name, "Leadtek IR", I2C_NAME_SIZE);
-- ir->l.code_length = 8;
-- ir->l.add_to_buf = add_to_buf_pvr2000;
- }
- break;
- case 0x30:
diff --git a/app-misc/lirc/files/lircd-0.8.6 b/app-misc/lirc/files/lircd-0.8.6
deleted file mode 100644
index 0a775a5..0000000
--- a/app-misc/lirc/files/lircd-0.8.6
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/files/lircd-0.8.6,v 1.1 2009/10/04 18:48:29 fauli Exp $
-
-PIDFILE=/var/run/lirc/${SVCNAME}.pid
-LIRCD_SYMLINKFILE=/dev/lircd
-LIRCD_SOCKET=/var/run/lirc/lircd
-
-depend() {
- provide lirc
-}
-
-start() {
- local retval
- ebegin "Starting lircd"
- rm -f ${LIRCD_SOCKET} && ln -s ${LIRCD_SOCKET} ${LIRCD_SYMLINKFILE}
- if [ $? -ne 0 ]; then
- eend $? "Unable to create symbolic link ${LIRCD_SYMLINKFILE}"
- return 1
- fi
-
- start-stop-daemon --start --quiet --pidfile "${PIDFILE}" --exec /usr/sbin/lircd -- \
- -P "${PIDFILE}" ${LIRCD_OPTS}
- retval=$?
-
- if [ ${retval} -ne 0 ]; then
- rm -f ${LIRCD_SOCKET}
- fi
-
- eend ${retval}
-}
-
-stop() {
- ebegin "Stopping lircd"
- rm -f ${LIRCD_SYMLINKFILE}
- start-stop-daemon --stop --quiet --pidfile "${PIDFILE}" --exec /usr/sbin/lircd
- eend $?
-}
diff --git a/app-misc/lirc/files/lircd.conf.2 b/app-misc/lirc/files/lircd.conf.2
deleted file mode 100644
index 191db37..0000000
--- a/app-misc/lirc/files/lircd.conf.2
+++ /dev/null
@@ -1,10 +0,0 @@
-# Options to pass to the lircd process
-
-# for devices with lirc-kernel-module
-#LIRCD_OPTS="-d /dev/lirc0"
-#LIRCD_OPTS="-d /dev/lirc"
-
-# for devices using the input-layer
-#LIRCD_OPTS="-H devinput -d /dev/input/by-path/pci-0000:00:0a.0--event-ir"
-# This should work, Bug #235107
-#LIRCD_OPTS="-H devinput name=*DVB*"
diff --git a/app-misc/lirc/files/lircmd b/app-misc/lirc/files/lircmd
deleted file mode 100755
index d383778..0000000
--- a/app-misc/lirc/files/lircmd
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/files/lircmd,v 1.2 2004/09/28 00:22:15 swegener Exp $
-
-depend() {
- need lircd
-}
-
-start() {
- ebegin "Starting lircmd"
- start-stop-daemon --start --quiet --exec /usr/sbin/lircmd
- eend $?
-}
-
-stop() {
- ebegin "Stopping lircmd"
- start-stop-daemon --stop --quiet --exec /usr/sbin/lircmd
- eend $?
-}
diff --git a/app-misc/lirc/files/modprobed.lirc b/app-misc/lirc/files/modprobed.lirc
deleted file mode 100644
index 2ed9558..0000000
--- a/app-misc/lirc/files/modprobed.lirc
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# For first serial receivers:
-#
-#options lirc_serial irq=4 io=0x3f8
-#options lirc_sir irq=4 io=0x3f8
-
-#
-# Detach first serial port from serial-driver.
-# Use this when you have your serial-port-driver statically
-# compiled into your kernel, or as a module but loaded before
-# the lirc-module.
-#
-#install lirc_serial setserial /dev/ttyS0 uart none; modprobe --ignore-install lirc_serial
-#
-#install lirc_sir setserial /dev/ttyS0 uart none; modprobe --ignore-install lirc_sir
-
-
-#
-# For parallel receivers:
-#
-#options lirc_parallel irq=7 io=0x3bc
-