summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVance M. Allen <vma_gentoo@vmacs.us>2020-10-30 20:09:52 -0600
committerVance M. Allen <vma_gentoo@vmacs.us>2020-10-30 20:09:52 -0600
commitf80b6e3ab58a84642250ff5e3fdd2669ca6f8d91 (patch)
treeb03a2ff747e85e6f670a23f58baec064b259b645
parentAdd support for vixie-cron (diff)
downloadvmacs-f80b6e3ab58a84642250ff5e3fdd2669ca6f8d91.tar.gz
vmacs-f80b6e3ab58a84642250ff5e3fdd2669ca6f8d91.tar.bz2
vmacs-f80b6e3ab58a84642250ff5e3fdd2669ca6f8d91.zip
Add support for phpMyAdmin-5.0.4
Signed-off-by: Vance M. Allen <vma_gentoo@vmacs.us>
-rw-r--r--dev-db/phpmyadmin/Manifest3
-rw-r--r--dev-db/phpmyadmin/files/postinstall-en-3.1.txt36
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-5.0.4.ebuild61
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
new file mode 100644
index 0000000..93b6aaf
--- /dev/null
+++ b/dev-db/phpmyadmin/Manifest
@@ -0,0 +1,3 @@
+AUX postinstall-en-3.1.txt 1160 BLAKE2B 0aa21601490830f93a784c1a3c09b90986d606d0086b128b37d6598c946e9ebe43f575f12ca5ee571db8520841a2c08624b567b721567d26ee02e1e3c4c9124e SHA512 7b50ab9f9e3a828bd9bff600550ea97712c28804467ab5900a52710d4adb0581fe33155a965dd3956fcd36cc153b1a18a1f001d88ac52d70c8288faf695f01ec
+DIST phpMyAdmin-5.0.4-all-languages.tar.xz 8049828 BLAKE2B 856990778fd63067523440ff662656bf746d62a273e7ba9a3a3020a530eeb5001abb0fc93787245a3dbef6117c93a77875af303f41534d7b49402c1a3b16110b SHA512 9516cecee01037ef29d7ef5fa3ea1fee019685ba738ff945e902bf90e8731b7e8c94f820779595bb3a8de2720bb44ee7d94785343096c972c6d476904d4451f8
+EBUILD phpmyadmin-5.0.4.ebuild 1556 BLAKE2B 989a8394159e188d8c1732c4daf269479cb0853e5e28ac8b74f2b537958209d000839a55b99ea7b881730b38ef1562d214498e98e7d37ca504fce44564d68865 SHA512 b4acf910c9693c42cff68eb04cd8a7c054b34553886b6584399ce042fa0282941f918d81e788d112263c71d50d159975fd5f34d24c88fff0be1821aded606f4a
diff --git a/dev-db/phpmyadmin/files/postinstall-en-3.1.txt b/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
new file mode 100644
index 0000000..4e72581
--- /dev/null
+++ b/dev-db/phpmyadmin/files/postinstall-en-3.1.txt
@@ -0,0 +1,36 @@
+If this is a new installation:
+
+1. Configure ${PN}:
+
+a) Create config.inc.php. You can use the web-based installer
+ (this requires the 'setup' USE flag to be enabled):
+
+ mkdir ${MY_INSTALLDIR}/config
+ chown ${VHOST_SERVER_UID}:${VHOST_SERVER_UID} ${MY_INSTALLDIR}/config
+
+ then go to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/setup/
+
+ once you've saved the configuration:
+
+ cp ${MY_INSTALLDIR}/config/config.inc.php ${MY_INSTALLDIR}/config.inc.php
+ rm -rf ${MY_INSTALLDIR}/config
+
+b) Alternatively, use an existing configuration:
+
+ cp <path to existing config.inc.php file> ${MY_INSTALLDIR}/
+
+c) Alternatively, use the sample config file:
+
+ cp ${MY_INSTALLDIR}/config.sample.inc.php ${MY_INSTALLDIR}/config.inc.php
+
+2. Be sure that the libraries/ directory is not visible. You can use the
+ provided .htaccess file.
+
+=================================================================
+
+If you are upgrading from an earlier version:
+
+1. If you are using ${PN}'s features for master/foreign tables, be sure to read
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/Documentation.html#col_com
+
+ You will need to perform the ALTER TABLE step yourself.
diff --git a/dev-db/phpmyadmin/phpmyadmin-5.0.4.ebuild b/dev-db/phpmyadmin/phpmyadmin-5.0.4.ebuild
new file mode 100644
index 0000000..89a5402
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-5.0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ >=dev-lang/php-7.1[ctype,filter,json(+),session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}