aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/acpid/acpid-2.0.17-r1.ebuild')
-rw-r--r--sys-power/acpid/acpid-2.0.17-r1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/sys-power/acpid/acpid-2.0.17-r1.ebuild b/sys-power/acpid/acpid-2.0.17-r1.ebuild
index 94923fea..51f77ad0 100644
--- a/sys-power/acpid/acpid-2.0.17-r1.ebuild
+++ b/sys-power/acpid/acpid-2.0.17-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://tedfelix.com/linux/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ia64 -ppc x86"
-IUSE="selinux"
+IUSE="selinux systemd"
RDEPEND="selinux? ( sec-policy/selinux-apm )"
DEPEND="${RDEPEND}"
@@ -38,7 +38,7 @@ src_install() {
newinitd "${FILESDIR}"/${PN}-2.0.16-init.d ${PN}
newconfd "${FILESDIR}"/${PN}-2.0.16-conf.d ${PN}
- systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
+ use systemd && systemd_dounit "${FILESDIR}"/systemd/${PN}.{service,socket}
}
pkg_postinst() {
@@ -49,4 +49,14 @@ pkg_postinst() {
elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
elog
fi
+
+ if use systemd; then
+ # files/systemd/acpid.socket -> ListenStream=/run/acpid.socket
+ mkdir -p "${ROOT}"/run
+
+ if ! grep -qs "^tmpfs.*/run " "${ROOT}"/proc/mounts ; then
+ echo
+ ewarn "You should reboot the system now to get /run mounted with tmpfs!"
+ fi
+ fi
}