aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2015-04-03 14:15:57 +0100
committerStuart Shelton <stuart@shelton.me>2015-04-03 14:15:57 +0100
commitafa84202e70d97afdcc58f583d4b95179d5e0320 (patch)
treeb6250748329ece75444b578a078caaf9e0dc966e /net-misc/usbip
parentAdd sys-libs/libeudev-3.0, virtual/libudev-215-r1 to provide libudev (diff)
downloadsrcshelton-afa84202e70d97afdcc58f583d4b95179d5e0320.tar.gz
srcshelton-afa84202e70d97afdcc58f583d4b95179d5e0320.tar.bz2
srcshelton-afa84202e70d97afdcc58f583d4b95179d5e0320.zip
Add net-misc/usbip-3.19 with CFLAGS fix
Diffstat (limited to 'net-misc/usbip')
-rw-r--r--net-misc/usbip/Manifest2
-rw-r--r--net-misc/usbip/usbip-3.19.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/usbip/Manifest b/net-misc/usbip/Manifest
new file mode 100644
index 00000000..0f3299fa
--- /dev/null
+++ b/net-misc/usbip/Manifest
@@ -0,0 +1,2 @@
+DIST linux-3.19.tar.xz 81688872 SHA256 be42511fe5321012bb4a2009167ce56a9e5fe362b4af43e8c371b3666859806c SHA512 d77bfd9b1cd524ac50bb5a93808955be2f9bcd2ec0badcc8aa6a63401e212f891fd14bd27c6441174ba5d70ab875b9e76c7ebc95f046e31aff1d40790d30351c WHIRLPOOL 76a17bb3d7c30cee19e135940f3607106efb2984061f946f0da9a2ddd602dc1bfc7e6f8970975cfb113d13f23a75415f39938204af266e2819e7a239b6f46778
+EBUILD usbip-3.19.ebuild 1383 SHA256 f4bfda76314f7b0d368308414404d26bd78b45573489dbd7a80e229427058c42 SHA512 95b4090224df57c21fe5828adddd07a299d888d1f56bde0aa3881b1184fcdb3f8efcfc4434f14c5b26c8fc6b32ef3667987384161292c7abe6b9b1c391131566 WHIRLPOOL 3b39cb0ec507f38d7e65d873858deddb4f405c7a374b67f8428d55b21b8a51d4bb165393966205d5ba611f1cee3d429587600bbc72ec0e6725328e79a2b35585
diff --git a/net-misc/usbip/usbip-3.19.ebuild b/net-misc/usbip/usbip-3.19.ebuild
new file mode 100644
index 00000000..4e2e5291
--- /dev/null
+++ b/net-misc/usbip/usbip-3.19.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/usbip/usbip-3.19.ebuild,v 1.1 2015/03/17 15:49:16 chithanh Exp $
+
+EAPI=5
+ETYPE="sources"
+K_NOUSENAME=1
+inherit autotools eutils kernel-2
+
+DESCRIPTION="Userspace utilities for a general USB device sharing system over IP networks"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="${KERNEL_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tcpd"
+RESTRICT=""
+
+RDEPEND=">=dev-libs/glib-2.6
+ sys-apps/hwids
+ >=sys-kernel/linux-headers-3.17
+ virtual/libudev
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README ../../../drivers/usb/usbip/usbip_protocol.txt"
+
+S=${WORKDIR}/linux-${PV}/tools/usb/${PN}
+
+src_prepare() {
+ # AC_SUBST([EXTRA_CFLAGS], ["-Wall -Werror -Wextra -std=gnu99"])
+ sed -i \
+ -e '/EXTRA_CFLAGS/s|\["-Wall -Werror -Wextra -std=gnu99"\]|["-std=gnu99"]|' \
+ configure.ac || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use tcpd || echo --without-tcp-wrappers) \
+ --with-usbids-dir=/usr/share/misc
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ elog "For using USB/IP you need to enable USB_IP_VHCI_HCD in the client"
+ elog "machine's kernel config and USB_IP_HOST on the server."
+}