summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild')
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
index c6faf78..28aedba 100644
--- a/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,20 +14,16 @@ HOMEPAGE="
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/osmocom/gr-osmosdr.git"
+ EGIT_REPO_URI="https://gitea.osmocom.org/sdr/gr-osmosdr.git"
else
- #commit
- COMMIT="a100eb024c0210b95e4738b6efd836d48225bd03"
- SRC_URI="https://github.com/osmocom/gr-osmosdr/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${COMMIT}"
- #release
- #SRC_URI="https://github.com/osmocom/gr-osmosdr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitea.osmocom.org/sdr/gr-osmosdr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ S="${WORKDIR}/${PN}"
fi
LICENSE="GPL-3"
SLOT="0/${PV}"
-IUSE="airspy airspyhf bladerf doc hackrf iqbalance python rtlsdr sdrplay soapy uhd xtrx"
+IUSE="airspy airspyhf bladerf doc hackrf iqbalance rtlsdr sdrplay soapy uhd xtrx"
RDEPEND="${PYTHON_DEPS}
dev-libs/boost:=
@@ -49,7 +45,7 @@ DEPEND="${RDEPEND}"
BDEPEND="
$(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -68,7 +64,7 @@ src_configure() {
-DENABLE_BLADERF="$(usex bladerf ON OFF)"
-DENABLE_HACKRF="$(usex hackrf ON OFF)"
-DENABLE_IQBALANCE="$(usex iqbalance ON OFF)"
- -DENABLE_PYTHON="$(usex python ON OFF)"
+ -DENABLE_PYTHON=ON
-DENABLE_RTL="$(usex rtlsdr ON OFF)"
-DENABLE_RTL_TCP="$(usex rtlsdr ON OFF)"
-DENABLE_SDRPLAY="$(usex sdrplay ON OFF)"
@@ -84,10 +80,7 @@ src_configure() {
src_install() {
cmake_src_install
- if use python; then
- find "${ED}" -name '*.py[oc]' -delete || die
- python_fix_shebang "${ED}"/usr/bin
- python_optimize
- fi
- mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+ find "${ED}" -name '*.py[oc]' -delete || die
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize
}