summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2019-12-08 14:38:12 -0600
committerDaniel Solano Gómez <gentoo@sattvik.com>2019-12-08 14:38:12 -0600
commit601577664a6edc6214b925885bc017a1fd0cde47 (patch)
treec3f089a1b3088b2dc3bcfa2fe80ee4f966516d59 /net-wireless
parentImport latest vmware-{modules,workstation} from stefantalpalaru-overlay (diff)
downloadsattvik-601577664a6edc6214b925885bc017a1fd0cde47.tar.gz
sattvik-601577664a6edc6214b925885bc017a1fd0cde47.tar.bz2
sattvik-601577664a6edc6214b925885bc017a1fd0cde47.zip
Update gr-osmosdr to 0.1.5
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-osmosdr/Manifest2
-rw-r--r--net-wireless/gr-osmosdr/gr-osmosdr-0.1.5.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-wireless/gr-osmosdr/Manifest b/net-wireless/gr-osmosdr/Manifest
index e3787aa..12bc329 100644
--- a/net-wireless/gr-osmosdr/Manifest
+++ b/net-wireless/gr-osmosdr/Manifest
@@ -1,4 +1,6 @@
AUX airspyhf.patch 22601 BLAKE2B 42b8f24e24845fc4b90854d0c41521da7289335f9aba10ebc1da42d432a6f2c21669d34b7cc11adf03f57b9f21879b9817a8f67628c4e5e2d80f379aab659b07 SHA512 7717debe00c812b357c14a0ae2c464cd18f5953f5e428afa2f754f38b16cdf18435e082b7aacb265ed69f68ae419fc316b70cc65ea32411493ecf2a441b5fa7b
DIST gr-osmosdr-0.1.4_p20180626.tar.xz 179568 BLAKE2B 223d23bd17edd5f4ee78237e509c79e5e7e49bbfb516009c3b5a715f386fcd138beea48e417d4576a7749cdb440736b6d92c8766b614bf617ef6b2bb4a293fda SHA512 8540da1f4d6936e0a97fa2f3e24af1866d44620fd7e7bc65b323364f67f1527fe8e0efd7bf0349be5e3d61f2ed24fa736c924ea0038e44fa3ab72848fe254a28
+DIST gr-osmosdr-0.1.5.tar.gz 278257 BLAKE2B f63704bd8d7e1fc86cfab256e8813716ac56a4b962f37d9e027df6234ee8e6d78a9d8459408d31ace4a3d6f46edfca0cc1eb9c1004b7052332ead1528cc5ec4b SHA512 5c028dcacf3cb94696eecdd31f4f09b31158c8ce12646d577535ba20942103899e5e21f001f2dd7d0a56eb58f17c2aa849139b495c61e21b60dd6678444b0983
EBUILD gr-osmosdr-0.1.4_p20180626-r4.ebuild 2247 BLAKE2B e3232228354179215d617c0096069aedebe817ac319269c77aef478cf995b65059eac8464ae63ef235b3f15c911431039ff9eede3722bf54e066a859007a1431 SHA512 bcd93db3720b88b7587625230fe2268fa8df30773b08d7a73c92163a4cb0265c2ded7a84b944b1a4cfc0872481ad27926e9fc5d14d8283a4bb084b95c1495eb9
+EBUILD gr-osmosdr-0.1.5.ebuild 1993 BLAKE2B 8696b2ce45fbc28af3fa28d07f5744e9e08e6202a5cd7c00100eb8f682b6325bffd2aea724f193cb262fa8b924a97b800b24c8e43bd329b1a887fcdfe1adf31d SHA512 dc269e0859a6da6afcd6cc1886cab6652648e916d221276d11c581cd13c6dcc30cd9083b414c5e87d1f991b24c03b915cdac1f945174348abdcb75816a49e06e
MISC metadata.xml 1010 BLAKE2B e4f3fbd3eb67c98876fb8df6db5d809011a8cf120134cb34ed63254b328e15914e696c80c848313c296c43cca71d0c61feb6788effacce30862d982ff6cf8975 SHA512 7144c3e40a28dc0e684f236ec7c70269a7734b3ca55df89f159e803904a43883563b8efb3b1bbc8f3f6eb96bf1c18040df4b1528f5bf1a674f8e8d875dbd69d3
diff --git a/net-wireless/gr-osmosdr/gr-osmosdr-0.1.5.ebuild b/net-wireless/gr-osmosdr/gr-osmosdr-0.1.5.ebuild
new file mode 100644
index 0000000..0c82298
--- /dev/null
+++ b/net-wireless/gr-osmosdr/gr-osmosdr-0.1.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GNU Radio source block for OsmoSDR and rtlsdr and hackrf"
+HOMEPAGE="http://sdr.osmocom.org/trac/wiki/GrOsmoSDR"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/osmocom/gr-osmosdr.git"
+else
+ SRC_URI="https://github.com/osmocom/gr-osmosdr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="airspy airspyhf bladerf fcd hackrf iqbalance mirisdr python rtlsdr sdrplay soapy uhd"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/boost:=
+ >=net-wireless/gnuradio-3.7_rc:0=[fcd?,${PYTHON_USEDEP}]
+ airspy? ( net-wireless/airspy )
+ airspyhf? ( net-wireless/airspyhf )
+ bladerf? ( >=net-wireless/bladerf-2018.08_rc1:= )
+ hackrf? ( net-libs/libhackrf:= )
+ iqbalance? ( net-wireless/gr-iqbal:=[${PYTHON_USEDEP}] )
+ mirisdr? ( net-libs/libmirisdr:= )
+ rtlsdr? ( >=net-wireless/rtl-sdr-0.5.4:= )
+ sdrplay? ( net-wireless/sdrplay )
+ soapy? ( net-wireless/soapysdr:= )
+ uhd? ( net-wireless/uhd:=[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/cheetah"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEFAULT=OFF
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_FILE=ON
+ -DENABLE_AIRSPY="$(usex airspy)"
+ -DENABLE_AIRSPYHF="$(usex airspyhf)"
+ -DENABLE_BLADERF="$(usex bladerf)"
+ -DENABLE_FCD="$(usex fcd)"
+ -DENABLE_HACKRF="$(usex hackrf)"
+ -DENABLE_IQBALANCE="$(usex iqbalance)"
+ -DENABLE_MIRI="$(usex mirisdr)"
+ -DENABLE_PYTHON="$(usex python)"
+ -DENABLE_RTL="$(usex rtlsdr)"
+ -DENABLE_RTL_TCP="$(usex rtlsdr)"
+ -DENABLE_SOAPY="$(usex soapy)"
+ -DENABLE_UHD="$(usex uhd)"
+ -DENABLE_SDRPLAY="$(usex sdrplay)"
+ -DENABLE_NONFREE="$(usex sdrplay)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use python; then
+ python_fix_shebang "${ED}"/usr/bin
+ fi
+}