summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2021-08-11 09:09:15 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2021-08-11 09:09:35 -0500
commite79f4e4c2165fba59379bfd1f33be7d3b7625642 (patch)
treec58f022323b9362f6f89895a81ee98df8be8f7c1
parentImport latest vmware-{modules,workstation} from stefantalpalaru-overlay (diff)
downloadsattvik-e79f4e4c2165fba59379bfd1f33be7d3b7625642.tar.gz
sattvik-e79f4e4c2165fba59379bfd1f33be7d3b7625642.tar.bz2
sattvik-e79f4e4c2165fba59379bfd1f33be7d3b7625642.zip
Add media-video/streamdeck-ui-1.1.2
Signed-off-by: Daniel Solano Gómez <gentoo@sattvik.com>
-rw-r--r--media-video/streamdeck-ui/Manifest3
-rw-r--r--media-video/streamdeck-ui/metadata.xml11
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-1.1.2.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/media-video/streamdeck-ui/Manifest b/media-video/streamdeck-ui/Manifest
new file mode 100644
index 0000000..7d99488
--- /dev/null
+++ b/media-video/streamdeck-ui/Manifest
@@ -0,0 +1,3 @@
+DIST streamdeck-ui-1.1.2.tar.gz 2573270 BLAKE2B a49638f1a9a62e893888f4c0e9a79cb90fee1a08132091fae5f511e4d52843c30eaf94806952aef77123633a4c913b1e54119f6092f8f0fcf8a548366514c014 SHA512 26c431f4c9a552d9dc79af9387b465d50a41de09d169a2d7642aef4c21e34cd6097981437c7b7a9f24b574fafa385cd4469f0a6a25a1de32b3b5a113f6a3f581
+EBUILD streamdeck-ui-1.1.2.ebuild 1186 BLAKE2B a0c0b3c024a834d43bc53d7f026f84433a83e1b7dbfa6665d0c70480f6acbd3f69c188c9d9b4ec859f3c7128790259b8e2e7f810ff3e592d1b61d629dc668e76 SHA512 560cf2a7ba1f3a006afcc74cbadb088b7fa6deaf55d88da1ddb30e0c148631f14905aab9aef8386c20d2311ed4b3819cb279190ca07f2879db7b27dc54ce2655
+MISC metadata.xml 340 BLAKE2B 0821dca2b83a5da9b0d87daaa2b3e835439a508a41eaf2adf173a3cca666fa4fa1b49ba0d571f0193c09004ef7fe42565ed75e29946ea08b2a8a5e2bd0835911 SHA512 2d31fac58ef66d6634c562565fa0d17b1c565b3c96fa75f98f86250ea206b7a98856e34ae4915087d6441c3efcd10e9775181b5609aafe5772dd2a863e88d2ea
diff --git a/media-video/streamdeck-ui/metadata.xml b/media-video/streamdeck-ui/metadata.xml
new file mode 100644
index 0000000..80b33db
--- /dev/null
+++ b/media-video/streamdeck-ui/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">timothycrosley/streamdeck-ui</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/streamdeck-ui/streamdeck-ui-1.1.2.ebuild b/media-video/streamdeck-ui/streamdeck-ui-1.1.2.ebuild
new file mode 100644
index 0000000..ae191af
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-1.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP},designer]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ dev-libs/hidapi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s#os.path.dirname(os.path.abspath(__file__))#'/usr/share/streamdeck-ui'#" streamdeck_ui/config.py
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/streamdeck-ui
+ doins streamdeck_ui/logo.png
+ doins -r streamdeck_ui/fonts
+ distutils-r1_src_install
+}